2 znl 12 znl_12 于 2013.01.14 17:26 提问

在允许条件下如何使用OpenSL ES

在条件允许范围内,我想使用 OpenSL` ES。例如 Android version >= 2.3

现在是在Android.mk

LOCAL_LDLIBS    += -lOpenSLES

如果Android version < 2.3,就不能正常运行。
在Android version >= 2.3的条件下,怎么样动态的加载 Open SL库?使用System.loadLibrary?

1个回答

cytown
cytown   2013.01.15 11:10
已采纳

做两套so,一套使用sl,一套不使用,在静态声明的时候根据Build.VERSION.SDK_INT来判断是否2.3以上,然后load不同的so。

static {
   if (Build.VERSION.SDK_INT >= 10) {
       System.loadLibrary("libjni_a");
   } else {
       System.loadLibrary("libjni_b");
   }
}
Csdn user default icon
上传中...
上传图片
插入图片