2 ycjunhua ycjunhua 于 2013.07.10 10:31 提问

c++boost库编译出问题

1> Assuming _WIN32_WINNT=0x0501 (i.e. Windows XP target).
1>libboost_thread-vc100-mt-1_49.lib(thread.obj) : error LNK2038: 检测到“_ITERATOR_DEBUG_LEVEL”的不匹配项: 值“0”不匹配值“2”(main.obj 中)
1>libboost_thread-vc100-mt-1_49.lib(tss_pe.obj) : error LNK2038: 检测到“_ITERATOR_DEBUG_LEVEL”的不匹配项: 值“0”不匹配值“2”(main.obj 中)
1>libboost_system-vc100-mt-1_49.lib(error_code.obj) : error LNK2038: 检测到“_ITERATOR_DEBUG_LEVEL”的不匹配项: 值“0”不匹配值“2”(main.obj 中)
1>LINK : warning LNK4098: 默认库“MSVCRT”与其他库的使用冲突;请使用 /NODEFAULTLIB:library
1>F:\myworkspace\code\cocos2d-x\3DGameWithForServer\Debug\3DGameWithForServer.exe : fatal error LNK1319: 检测到 3 个不匹配项
1>
1>生成失败。

4个回答

seuliujiaguo
seuliujiaguo   2014.12.11 09:51

楼主解决了吗?我也出现了同样的错误啊。

zhang_jing5
zhang_jing5   2016.02.06 15:56

我也同样的错误啊!要换个编译器吗?

m0_37579176
m0_37579176   2017.12.26 14:20

手把手教你:解决boost库编译使用后thread类使用报错的方法
原创 2014年10月31日 15:35:54 标签:Boost_1_53_0 /thread /mt mtd md 1455
报错如下:

libboost_thread-vc110-mt-1_53.lib(thread.obj) : error LNK2038....

error LNK2038: 检测到“_ITERATOR_DEBUG_LEVEL”的不匹配项: 值“0”不匹配值“2”(the_main.obj 中)

原因:

debug使用了release文件

因为thread在编译中一共出现了

libboost_thread-vc110-mt-1_53.lib

libboost_thread-vc110-mt-gd-1_53.lib

libboost_thread-vc110-mt-s-1_53.lib

libboost_thread-vc110-mt-sgd-1_53.lib

这4个lib

mt:表示多线程,d:表示debug,s:标识static

指定与你项目连接的运行期库
/MT多线程应用程序
/Mtd多线程应用程序(DEBUG)
/MD多线程DLL
/MDd多线程DLL(DEBUG)

如果你在项目中是这样添加:项目属性---链接器---输入---附加依赖项中:D:\developSoftware\boost1\boost_1_53_0\stage\lib*.lib

那么即使你的连接库中都含有debug和relase版本的库,但是release版本的顺序放在了debug前面,就会出现上述原因

解决方法:

在项目属性---链接器---输入---附加依赖项中添加下面的。

D:\developSoftware\boost1\boost_1_53_0\stage\lib*mt-gd*.lib

m0_37579176
m0_37579176   2017.12.26 14:22

就是附加依赖项里面输入各种库的lib把debug版本和release版本全输入进去导致的,debug配置页附加依赖项输入带gd版本的,release配置页输入不带d的版本,就OK啦。

Csdn user default icon
上传中...
上传图片
插入图片
准确详细的回答,更有利于被提问者采纳,从而获得C币。复制、灌水、广告等回答会被删除,是时候展现真正的技术了!