2 myc 100 myc_100 于 2013.07.19 17:24 提问

android:actionBarStyle 需要 API 11版本

当在xml中使用ActionBarSherlock时:

<item name="android:actionBarStyle">@style/Widget.Styled.ActionBar</item>

有如下的错误:

android:actionBarStyle requires API level 11 (current min is 8) error

我使用它把带有actionbar 的程序移植到2.2 设备上。
如何同时使用它们?

<item name="actionBarStyle">@style/Widget.Styled.ActionBar</item>
<item name="android:actionBarStyle">@style/Widget.Styled.ActionBar</item>

2个回答

Jave_
Jave_   2013.07.20 08:40

可以使用ActionBarSherlock

shaojie519
shaojie519   2013.07.22 11:48

sdk的版本设置成最新的(4.2.2),使用ActionBarSherlock去兼容到2.2的版本。然后在自己的style里面去继承ActionBarSherlock里面的style即可

Csdn user default icon
上传中...
上传图片
插入图片
准确详细的回答,更有利于被提问者采纳,从而获得C币。复制、灌水、广告等回答会被删除,是时候展现真正的技术了!