2 kangjianghu kangjianghu 于 2014.10.12 16:12 提问

ubuntu 13.04搭建交叉编译环境

ky@ubuntu:~$ sudo apt-get install gcc g++ binutils patch bzip2 flex bison make autoconf gettext texinfo unzip sharutils subversion libncurses5-dev ncurses-term zlib1g-dev
Reading package lists... Done
Building dependency tree

Reading state information... Done
flex is already the newest version.
g++ is already the newest version.
subversion is already the newest version.
bzip2 is already the newest version.
gettext is already the newest version.
patch is already the newest version.
gcc is already the newest version.
unzip is already the newest version.
make is already the newest version.
binutils is already the newest version.
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
libncurses5-dev : Depends: libncurses5 (= 5.9-4) but 5.9-10ubuntu4 is to be installed
Depends: libtinfo-dev (= 5.9-4) but it is not going to be installed
Depends: ncurses-bin (= 5.9-4) but 5.9-10ubuntu4 is to be installed
zlib1g-dev : Depends: zlib1g (= 1:1.2.3.4.dfsg-3ubuntu4) but 1:1.2.7.dfsg-13ubuntu2 is to be installed
E: Unable to correct problems, you have held broken packages.

请问各位大神一下,怎么解决
The following packages have unmet dependencies:
libncurses5-dev : Depends: libncurses5 (= 5.9-4) but 5.9-10ubuntu4 is to be installed
Depends: libtinfo-dev (= 5.9-4) but it is not going to be installed
Depends: ncurses-bin (= 5.9-4) but 5.9-10ubuntu4 is to be installed
zlib1g-dev : Depends: zlib1g (= 1:1.2.3.4.dfsg-3ubuntu4) but 1:1.2.7.dfsg-13ubuntu2 is to be installed

Csdn user default icon
上传中...
上传图片
插入图片