2 luyouzi luyouzi 于 2014.11.29 09:44 提问

32为Linux安卓AVD启动报错

Andoid的朋友,在吗?请教个问题。
我启动Adnroid的AVD时报错如下:

Starting emulator for AVD 'qq'
ERROR: 32-bit Linux Android emulator binaries are DEPRECATED, to use them you will have to do at least one of the following:
- Use the '-force-32bit' option when invoking 'emulator'.
- Set ANDROID_EMULATOR_FORCE_32BIT to 'true' in your environment.
Either one will allow you to use the 32-bit binaries, but please be
aware that these will disappear in a future Android SDK release. Consider moving to a 64-bit Linux system before that happens.

我的系统是:
ubuntu 10.4,
jdk 1.7
adt-bundle-windows-x86-20140702.zip,
eclipse就是adt压缩文件中的打包文件。

网上找了仅有的几个解决办法,都不好使。
是不是也是跟你类似的问题呢?
若有解答请回复:1790447697@qq.com.cn
谢谢。

2个回答

Rocloud
Rocloud   Rxr 2014.11.29 12:04
已采纳

当使用android的AVD时提示以下错误
Starting emulator for AVD 'NexusOne' ERROR: 32-bit Linux Android emulator binaries are DEPRECATED, to use them you will have to do at least one of the following: - Use the '-force-32bit' option when invoking 'emulator'. - Set ANDROID_EMULATOR_FORCE_32BIT to 'true' in your environment. Either one will allow you to use the 32-bit binaries, but please be aware that these will disappear in a future Android SDK release. Consider moving to a 64-bit Linux system before that happens.

提示我们有两种方法可以解决:
1)、修改~/.bashrc,添加一句:export ANDROID_EMULATOR_FORCE_32BIT=true;重启;
2)、
In Eclipse, click your Android project folder and then select Run > Run Configurations...
In the left panel of the Run Configurations dialog, select your Android project run configuration or create a new configuration.
Click the Target tab.
In the Additional Emulator Command Line Options field, enter:
-force-32bit
Run your Android project using this run configuration.

luyouzi
luyouzi nothing have been happened. thanks very much.
大约 3 年之前 回复
wowo86886
wowo86886   2014.11.29 13:07

错误提示,意思你在64位系统上启动32位的仿真模拟器。建议在32位系统下尝试。

luyouzi
luyouzi thanks.大体意思我 懂,可是 还 没解决 .
大约 3 年之前 回复
Csdn user default icon
上传中...
上传图片
插入图片
准确详细的回答,更有利于被提问者采纳,从而获得C币。复制、灌水、广告等回答会被删除,是时候展现真正的技术了!