2 taochen3670 taochen3670 于 2015.05.26 17:49 提问

ubuntu12.04 更新软件的时候总是失败

。在计算升级时遇到一个无法解决的问题。 请汇报这个有关“update-manager”软件包的错误,并且将下列错误信息包含在错误报告中: 'E:错误,pkgProblemResolver::Resolve 发生故障,这可能是有软件包被要求保持现状的缘故。

下列软件包未满足的依赖关系: libsm6:i386: openssh-client: openssh-server: Depends: openssh-client (= 1:5.9p1-5ubuntu1.4) 但是将要安装 1:5.9p1-5ubuntu1.4 Depends: upstart-job 但是它是虚拟软件包'

5个回答

devmiao
devmiao   Ds   Rxr 2015.05.26 17:54

12.04太老了,现在我们一般都用15.04了,建议重装下系统

Han_Cloud1008
Han_Cloud1008   2015.05.26 18:28

输入sudo rm /var/lib/apt/lists/* -vf 然后再更新试试

q3733353520
q3733353520   2015.05.26 18:36

ubuntu的依赖关系可以要你求生不得,求死不能

DZL_ACE
DZL_ACE   2015.05.26 20:01

很多时候旧系统的更新维护都不到位,建议重装系统

u012271952
u012271952   2015.05.27 10:35

建议重装系统,其实很容易的哦,直接从官网下载安装。

Csdn user default icon
上传中...
上传图片
插入图片