2 u011706563 u011706563 于 2015.06.03 14:52 提问

websocket 如何兼容低版本浏览器?

[WebSocket] debug enabled
[WebSocket] policy file: xmlsocket://211.95.3.194:843
[WebSocket] cannot connect to Web Socket server at ws://211.95.3.194:11113/demo01/MyHtml.html?message_to=&message_me= (SecurityError: Error #2048)
make sure the server is running and Flash socket policy file is correctly placed
[WebSocket] closed

我从网上下载了很多demo 大致都是flash+websocket.js+WebSocketMain.swf但为什么总是出这个错?

5个回答

guwei4037
guwei4037   Ds   Rxr 2015.06.03 19:45

websocket是html5新增加的一种通信协议,低版本的浏览器不支持。
http://fmbip.com/litmus#mdz_websockets

qq_24429793
qq_24429793 回复极简: 不支持就不能兼容了 你特么什么逻辑
6 个月之前 回复
guwei4037
guwei4037 莫名其妙的攻击人,真不知道是种什么样的心理。
一年多之前 回复
guwei4037
guwei4037 估计你比菜狗还要菜。满口的脏话。
一年多之前 回复
DOwenlong
DOwenlong 回复极简: 菜狗
一年多之前 回复
guwei4037
guwei4037 回复小太阳-双仔: 本来就不支持,怎么兼容?你不懂还没有素质,人品太差咯。
一年多之前 回复
rqs849469198
rqs849469198 谁还不知道不支持,问题是如何兼容, 真TM 瞎几 回答, 不会潜水去
一年多之前 回复
rqs849469198
rqs849469198 谁还不知道不支持,问题是如何兼容, 真TM 瞎几 回答, 不会潜水去
一年多之前 回复
oyljerry
oyljerry   Ds   Rxr 2015.06.03 19:39

低版本浏览器就不需要支持了,提示不能支持就可以了

yangjuxiang
yangjuxiang   2015.09.01 11:18

websocket 如何兼容低版本浏览器 这个问题解决了吗?

rememberme001
rememberme001   2017.03.02 09:08

用flash可以让低版本兼容 WebSocketMain.swf

miansuo7631
miansuo7631   2017.08.07 11:00

楼主你好。这个问题你解决了没有?我也遇到和你一样的问题了

qq_27437301
qq_27437301 我是偶尔会报这个错....
2 个月之前 回复
u013705066
u013705066 一样 解决了么
3 个月之前 回复
Csdn user default icon
上传中...
上传图片
插入图片