2 l403040463 l403040463 于 2015.06.29 22:20 提问

requires compiler compliance level 5.0 or 6.0.

我之前导入了一个项目,报错,原因是代码里面的switch case语句用于判断String类型的变量了,但这个功能只能在jdk1.7或以上才可以,而我的jdk是1.6,于是就报错:
Android requires compiler compliance level 5.0 or 6.0. Found '1.7' instead. Please use Android Tools > Fix Project Properties.

网上的解决方法如下:(但我试了不行)
1.项目右键 ->android tools->Fix Project

2.如果不可以,检查Project->Properties->Java Compiler确认JDK compliance被设置为1.6, 并且enable specific seetings,经过这两步问题基本解决。

我的解决方法如下:
首先我升级jdk到1.7:
图片说明

eclipse也重新配置了jdk的路径:
图片说明

使用1.7版本的jdk,并且把项目也设置了enable specific setting了:
图片说明

图片说明

我把我能做的都做了,但还是报同样的错误,为什么呢,跪求大神指导!

2个回答

l403040463
l403040463   2015.06.30 09:59

有大神知道吗??急求

crazy1235
crazy1235   Ds   Rxr 2015.06.30 10:40

你重启试试吧。。还有环境变量也需要重新配置一下。

Csdn user default icon
上传中...
上传图片
插入图片