2 zxy1012947234 zxy1012947234 于 2015.06.30 20:51 提问

请问如何让SQL2008附加上2008 R2的数据?无法兼容……

新人正在自学……我之前在R2上制作的数据库,另一台电脑是2008版本,却无法附加上去。说什么我的版本比较高,无法兼容,请问有什么好的解决方法吗

5个回答

Carry_Dominator
Carry_Dominator   2015.06.30 21:40
已采纳

这个你把自己的数据库在任务里做成脚本,在另一个r2上直接执行脚本就可以了,另一个方法就是你把版本低的升级到r2版本,我想第一种是最好的!

oyljerry
oyljerry   Ds   Rxr 2015.06.30 21:05

低版本数据库当然不能支持高版本数据库建立的,只有向前兼容

zwz187
zwz187   2015.06.30 22:39

链接:http://pan.baidu.com/s/1pJwuzij 密码:jugl,sql 2008 r2 版本

wxg8681
wxg8681   2015.07.01 11:04

把2008版本升级到2008R2吧。一劳永逸

qq_15540219
qq_15540219   2015.07.02 14:33

把数据库生成脚本,在另一个上直接执行

Csdn user default icon
上传中...
上传图片
插入图片