2 u013399457 u013399457 于 2015.07.05 20:54 提问

java1.5版本jvm开启后怎么关闭,

我的oracle 自带 jvm1.5版本,我电脑安装了1.7版本,我点击了1.5版本的 java.exe,之后打开eclipse显示jvm1.5版本过低,必须要1.6或以上的,我怎么能关闭jvm1.5版本,重新开启1.7版本的jvm

7个回答

devmiao
devmiao   Ds   Rxr 2015.07.05 22:46

卸载1.5重新安装1.7就可以了。

lingfeiwen
lingfeiwen   2015.07.06 17:36

楼主为什么要双击启动java.exe呢?
开启eclipse需要什么样的JDK版本,这是eclipse的运行要求,eclipse也是java编写的,运行需要JDK的支持,看楼主的问题描述,意思是eclipse是运行在JDK1.6的基础上。
eclipse怎么是读取本地的JDK环境变量配置来加载的。楼主可改变本地eclipse环境变量的配置,让其指向1.6(或1.6以上)的JDK。
如果不想改变本地的JDK环境变量配置,还有种办法,就是在eclispe.ini文件中指定使用的JDK版本。
-vm
D:/jdk1.5-x86/bin/javaw.exe
-vmargs
-Dosgi.requiredJavaVersion=1.5

cuiwei1026522829
cuiwei1026522829   Ds   Rxr 2015.07.05 22:27

杀死线程,任务管理器,把jdk相关的杀死

yuke198907
yuke198907   2015.07.06 09:35

在环境变量中设置一下jdk为1.7版本的

u010875487
u010875487   2015.07.06 10:17

oracle的1.5,现在用的时候是为了打开sql develpe吧。机器上可以安装多个版本的jdk,主要是你在环境变量里面,配置的是那个。

edouardzyc
edouardzyc   2015.07.06 12:05

进程里面 java.exe 停止就可以了

zhangweigangweiwu
zhangweigangweiwu   2015.07.08 17:02

你看下你的eclipse.ini中配置的jvm是一点几的,也可以在eclipse 中配置对应的jdk 环境变量改成1.7的

Csdn user default icon
上传中...
上传图片
插入图片