2 u010865909 u010865909 于 2015.07.27 00:24 提问

安装Eclipse 出现的问题,求解决。急用啊。感谢了。。。

org.osgi.framework.BundleException: Could not resolve module: org.eclipse.ant.ui [29]
Unresolved requirement: Require-Bundle: org.eclipse.jface.text; bundle-version="[3.5.0,4.0.0)"; resolution:="optional"
-> Bundle-SymbolicName: org.eclipse.jface.text; bundle-version="3.10.0.v20150603-1752"
org.eclipse.jface.text [173]
Unresolved requirement: Require-Bundle: org.eclipse.core.runtime; bundle-version="[3.5.0,4.0.0)"
-> Bundle-SymbolicName: org.eclipse.core.runtime; bundle-version="3.11.0.v20150405-1723"; singleton:="true"
org.eclipse.core.runtime [50]
Unresolved requirement: Require-Bundle: org.eclipse.core.jobs; bundle-version="[3.2.0,4.0.0)"; visibility:="reexport"
-> Bundle-SymbolicName: org.eclipse.core.jobs; bundle-version="3.7.0.v20150330-2103"; singleton:="true"
org.eclipse.core.jobs [45]
Unresolved requirement: Require-Capability: osgi.ee; filter:="(&(osgi.ee=JavaSE)(version=1.7))"
Unresolved requirement: Require-Bundle: org.eclipse.ui.views; bundle-version="[3.2.0,4.0.0)"; resolution:="optional"
-> Bundle-SymbolicName: org.eclipse.ui.views; bundle-version="3.8.0.v20150422-0725"; singleton:="true"
org.eclipse.ui.views [227]
Unresolved requirement: Require-Bundle: org.eclipse.core.runtime; bundle-version="[3.11.0,4.0.0)"
-> Bundle-SymbolicName: org.eclipse.core.runtime; bundle-version="3.11.0.v20150405-1723"; singleton:="true"
Unresolved requirement: Require-Bundle: org.eclipse.ant.core; bundle-version="[3.2.0,4.0.0)"
-> Bundle-SymbolicName: org.eclipse.ant.core; bundle-version="3.4.0.v20150428-1928"; singleton:="true"
org.eclipse.ant.core [27]
Unresolved requirement: Require-Bundle: org.eclipse.core.variables; bundle-version="[3.1.0,4.0.0)"
-> Bundle-SymbolicName: org.eclipse.core.variables; bundle-version="3.2.800.v20130819-1716"; singleton:="true"
org.eclipse.core.variables [53]
Unresolved requirement: Require-Bundle: org.eclipse.core.runtime; bundle-version="[3.3.0,4.0.0)"
-> Bundle-SymbolicName: org.eclipse.core.runtime; bundle-version="3.11.0.v20150405-1723"; singleton:="true"
Unresolved requirement: Require-Bundle: org.eclipse.ui.workbench.texteditor; bundle-version="[3.5.0,4.0.0)"; resolution:="optional"
-> Bundle-SymbolicName: org.eclipse.ui.workbench.texteditor; bundle-version="3.9.100.v20141023-1946"; singleton:="true"
org.eclipse.ui.workbench.texteditor [232]
Unresolved requirement: Require-Bundle: org.eclipse.core.runtime; bundle-version="[3.5.0,4.0.0)"
-> Bundle-SymbolicName: org.eclipse.core.runtime; bundle-version="3.11.0.v20150405-1723"; singleton:="true"
Unresolved requirement: Require-Bundle: org.eclipse.ui.editors; bundle-version="[3.2.0,4.0.0)"; resolution:="optional"
-> Bundle-SymbolicName: org.eclipse.ui.editors; bundle-version="3.9.0.v20150213-1939"; singleton:="true"
org.eclipse.ui.editors [214]
Unresolved requirement: Require-Bundle: org.eclipse.core.runtime; bundle-version="[3.7.0,4.0.0)"
-> Bundle-SymbolicName: org.eclipse.core.runtime; bundle-version="3.11.0.v20150405-1723"; singleton:="true"
Unresolved requirement: Require-Bundle: org.eclipse.ui.ide; bundle-version="[3.2.0,4.0.0)"; resolution:="optional"
-> Bundle-SymbolicName: org.eclipse.ui.ide; bundle-version="3.11.0.v20150510-1749"; singleton:="true"
org.eclipse.ui.ide [217]
Unresolved requirement: Require-Bundle: org.eclipse.core.resources; bundle-version="[3.7.0,4.0.0)"; resolution:="optional"
-> Bundle-SymbolicName: org.eclipse.core.resources; bundle-version="3.10.0.v20150423-0755"; singleton:="true"
org.eclipse.core.resources [48]
Unresolved requirement: Require-Bundle: org.eclipse.ant.core; bundle-version="[3.1.0,4.0.0)"; resolution:="optional"
-> Bundle-SymbolicName: org.eclipse.ant.core; bundle-version="3.4.0.v20150428-1928"; singleton:="true"
Unresolved requirement: Require-Bundle: org.eclipse.core.expressions; bundle-version="[3.2.0,4.0.0)"
-> Bundle-SymbolicName: org.eclipse.core.expressions; bundle-version="3.5.0.v20150421-2214"; singleton:="true"
org.eclipse.core.expressions [39]
Unresolved requirement: Require-Bundle: org.eclipse.core.runtime; bundle-version="[3.3.0,4.0.0)"
-> Bundle-SymbolicName: org.eclipse.core.runtime; bundle-version="3.11.0.v20150405-1723"; singleton:="true"
Unresolved requirement: Require-Bundle: org.eclipse.core.runtime; bundle-version="[3.2.0,4.0.0)"
-> Bundle-SymbolicName: org.eclipse.core.runtime; bundle-version="3.11.0.v20150405-1723"; singleton:="true"

at org.eclipse.osgi.container.Module.start(Module.java:434)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1561)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

!ENTRY org.eclipse.compare 4 0 2015-07-27 00:21:10.073
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.eclipse.compare [30]
Unresolved requirement: Require-Bundle: org.eclipse.ui; bundle-version="[3.5.0,4.0.0)"
-> Bundle-SymbolicName: org.eclipse.ui; bundle-version="3.107.0.v20150507-1945"; singleton:="true"
org.eclipse.ui [210]
Unresolved requirement: Require-Bundle: org.eclipse.core.runtime; bundle-version="[3.2.0,4.0.0)"
-> Bundle-SymbolicName: org.eclipse.core.runtime; bundle-version="3.11.0.v20150405-1723"; singleton:="true"
org.eclipse.core.runtime [50]
Unresolved requirement: Require-Bundle: org.eclipse.core.jobs; bundle-version="[3.2.0,4.0.0)"; visibility:="reexport"
-> Bundle-SymbolicName: org.eclipse.core.jobs; bundle-version="3.7.0.v20150330-2103"; singleton:="true"
org.eclipse.core.jobs [45]
Unresolved requirement: Require-Capability: osgi.ee; filter:="(&(osgi.ee=JavaSE)(version=1.7))"

at org.eclipse.osgi.container.Module.start(Module.java:434)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1561)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

!ENTRY org.eclipse.compare.core 4 0 2015-07-27 00:21:10.075
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.eclipse.compare.core [31]
Unresolved requirement: Require-Bundle: org.eclipse.core.runtime; bundle-version="[3.2.0,4.0.0)"
-> Bundle-SymbolicName: org.eclipse.core.runtime; bundle-version="3.11.0.v20150405-1723"; singleton:="true"
org.eclipse.core.runtime [50]
Unresolved requirement: Require-Bundle: org.eclipse.core.jobs; bundle-version="[3.2.0,4.0.0)"; visibility:="reexport"
-> Bundle-SymbolicName: org.eclipse.core.jobs; bundle-version="3.7.0.v20150330-2103"; singleton:="true"
org.eclipse.core.jobs [45]
Unresolved requirement: Require-Capability: osgi.ee; filter:="(&(osgi.ee=JavaSE)(version=1.7))"

at org.eclipse.osgi.container.Module.start(Module.java:434)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1561)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

求解决怎么回事

10个回答

caozhy
caozhy   Ds   Rxr 2015.07.27 00:37

eclipse的安装最简单了,先安装好jdk,然后下载eclipse,解压缩就可以运行。你看看你是不是下载或者解压有问题。

Evankaka
Evankaka   Ds   Rxr 2015.07.27 08:40

1重新安装JDK,
2重新解压eclipse(jdk配置好环境变量后,直接解压就可以运行了)

ze631863
ze631863   2015.07.27 12:26

建议在官网下载好jdk和Eclipse,然后先安装jdk,安装好之后配置环境变量(方法:【win键+Pause/Break键】--->【点击·高级系统设置】--->
【环境变量】--->【新建一个path变量】--->【将jdk路径下的bin目录作为变量值】(这个方法虽然没那么规范,但是也能正常使用)),然后打开
命令行,输入java或javac命令,如果有显示关于java的信息,说明jdk安装成功,接着解压Eclipse,打开eclipse.exe就可以进行编程了

CSDNXIAON
CSDNXIAON   2015.07.27 00:34

解决导入eclipse中出现乱码问题
安装eclipse过程过程中出现的问题
Eclipse中安卓开发环境安装出现的问题解决方法
----------------------同志你好,我是CSDN问答机器人小N,奉组织之命为你提供参考答案,编程尚未成功,同志仍需努力!

yuke198907
yuke198907   2015.07.27 08:19

你的安装过程是什么样的,一般来说解压就可以直接用的

tongyi55555
tongyi55555   2015.07.27 08:42

没有安装过,都是解压缩后直接启动,你这个错误是在哪里出现的,启动时么?

ze631863
ze631863   2015.07.27 12:36

下载那些资源需要连接到国外网站,有需要可以分享给你

sina_2831808769
sina_2831808769   Rxr 2015.07.27 22:32

确定jdk环境安装好了就去官网下载Eclipse,

qq_33819621
qq_33819621   2016.01.22 11:49

最新版的eclipse遇到该问题。。。。。

flamingotrust
flamingotrust   2016.11.23 15:00

如果是NeonN版本的话,有一种可能是JDK的问题。
本地的JDK删掉换成1.8试试

Csdn user default icon
上传中...
上传图片
插入图片