2 xierfly xierfly 于 2016.01.29 17:41 提问

Jenkins PHP 集成构建时,test过不去
php

图片说明

2个回答

devmiao
devmiao   Ds   Rxr 2016.01.30 06:31
xierfly
xierfly 3Q,但是,这个没有说测试方面的东西。我看了一下下面的sh脚本,就是一个打包相关的逻辑;
接近 2 年之前 回复
xierfly
xierfly   2016.01.30 14:42

问题补充:
1、采用Phing(2.3)+phpunit(4.8.21)进行测试;
2、环境是Wamp:php5.5 ;
3、phpunit 采用的是phar手动设置;参考站点:http://jenkins-php.org/installation.html
一直提示上面的问题,我看了一下phing下面的代码:发现if (version_compare($version, '3.6.0') < 0) {
throw new BuildException("PHPUnitTask requires PHPUnit version >= 3.6.0", $this->getLocation());
}
_可是,phing下面的phpunit下,并没有Version.php文件。

怀疑是,build.xml配置问题;或者是Phpunit依赖问题;查了两天,无果。
希望,搞过的,给与指点。不胜感激!!

Csdn user default icon
上传中...
上传图片
插入图片
准确详细的回答,更有利于被提问者采纳,从而获得C币。复制、灌水、广告等回答会被删除,是时候展现真正的技术了!