2 u011359326 u011359326 于 2016.01.31 15:43 提问

如何理解编程中最没用的东西是源代码,最有用的东西是算法和数据结构

编程中最没用的东西是源代码,最有用的东西是算法和数据结构
举个简单的算法和数据结构瞧瞧,谢谢

4个回答

caozhy
caozhy   Ds   Rxr 2016.01.31 15:55
已采纳

这是胡扯,那微软的windows为什么不开源?说源代码没用的,把你的代码都开源啊。

caozhy
caozhy   Ds   Rxr 2016.01.31 15:57

任何话都有上下文。这里不过是说,对于一个学习编程的人来说,学明白算法再看代码,比在你不懂算法的前提下看人家的代码有效率的多。
好比学习舞蹈,你需要的是学习分解动作,而不是直接模仿人家的姿势。

caozhy
caozhy   Ds   Rxr 2016.01.31 16:07

算法和数据结构是一门课程的名字,其中提到的都是一些基础概念而已,它们当然重要和有用,但是也就是基础而已。

再比如动态规划,这是一种最常见的算法:

http://ask.csdn.net/questions/235038

参考问题和我的回答。你可以先不管这个算法,自己去尝试解答这个题目。然后再搞明白我的程序(或者lz的程序),看看算法有没有用。

qw2384008
qw2384008   2016.01.31 16:14

.版本 2

.子程序 CALL_拾取
.参数 对象地址, 整数型
.参数 物品地址, 整数型, , 地址段
.局部变量 物品EBP, 整数型
.局部变量 拾取EBP, 整数型

物品EBP = 十六到十3 (#物品栏)
拾取EBP = 十六到十3 (#拾取CALL)
置入代码 ({ 96, 139, 181, 8, 0, 0, 0, 139, 54, 139, 141, 252, 255, 255, 255, 139, 12, 49, 255, 181, 12, 0, 0, 0, 139, 133, 248, 255, 255, 255, 255, 208, 97 })

Csdn user default icon
上传中...
上传图片
插入图片
准确详细的回答,更有利于被提问者采纳,从而获得C币。复制、灌水、广告等回答会被删除,是时候展现真正的技术了!