2 chamiyouyan CHAMIYOUYAN 于 2016.02.02 23:16 提问

CUDA7.5+VS2012配置问题 5C

小弟最近刚刚进入CUDA并行编程领域,下载了CUDA Toolkit 7.5和VS2012,安装好了以后开始编程,新建一个工程,自己带了一个实例,运行不成功,运行结果如下:
cudaSetDevice failed! Do you have a CUDA-capable GPU installed?addWithCuda failed!
贴上我的GPU情况截图:
GPU基本情况
还望大师帮我指点,怎么调通这个东西啊。。。小弟在此谢过了!

3个回答

caozhy
caozhy   Ds   Rxr 2016.02.03 07:14

驱动的问题,你的GT240规格没问题,完全支持CUDA。看下你的sdk用的是cuda什么版本,240和260不同,它只支持CUDA 1.x。

CHAMIYOUYAN
CHAMIYOUYAN 我下载的是CUDA toolkit7.5,安装好了就可以在VS2012中新建CUDA项目,不需要自己进行任何设置,您说的这个CUDA1.x是说需要我自己下载CUDA1.X的安装包,还有一个叫CUDA1.X SDK的东东是吧?还有您说的驱动有问题,那我能去哪里找适合7.5的驱动呢?还是只能用1.X?
接近 2 年之前 回复
u012177192
u012177192   2016.10.19 15:34

我安装了cuda7.5版本的他为什么不能再vs项目模板中显示出来

oyljerry
oyljerry   Ds   Rxr 2016.02.02 23:56

看上去提示是你的gpu不能支持cuda

CHAMIYOUYAN
CHAMIYOUYAN 哥哥,关键是不知道为啥啊~
接近 2 年之前 回复
CHAMIYOUYAN
CHAMIYOUYAN 哥哥,关键是不知道为啥啊~
接近 2 年之前 回复
Csdn user default icon
上传中...
上传图片
插入图片
准确详细的回答,更有利于被提问者采纳,从而获得C币。复制、灌水、广告等回答会被删除,是时候展现真正的技术了!