2 keterdo KeterDo 于 2016.03.01 10:56 提问

MAC上npm依赖安装问题

在mac本上 npm安装依赖时,
node-pre-gyp install --fallback-to-build
这条命令执行时卡住,没反映,谁遇到过这种情况,是怎么解决的?
谢谢。

2个回答

caozhy
caozhy   Ds   Rxr 2016.03.07 05:59
qq_22095051
qq_22095051   2016.05.10 20:34

我刚才也遇到了这个问题,去google了一下,是python版本的问题,我自己装了python3.4而只有Mac OS自带的python2.7可用。所以要先用命令指定$ npm config set python /path/to/executable/python2.7指定python版本,然后运行npm install -g node-gyp。希望有用:D

Csdn user default icon
上传中...
上传图片
插入图片
准确详细的回答,更有利于被提问者采纳,从而获得C币。复制、灌水、广告等回答会被删除,是时候展现真正的技术了!