2 bbbigorange bbbigorange 于 2016.03.04 13:27 提问

本人新手,请教老鸟一个Android studio的support问题。问题可能问得也不对~请轻喷。 50C

Android studio更新了6.0的SDK后,先选择6.0建了个项目,然后删掉了。之后选择4.3作为minimum SDK后,新建的项目中出现了v7 support的语句,WHY?是版本间的问题吗?此类问题该如何解决?

3个回答

dongfeng9ge
dongfeng9ge   Ds   Rxr 2016.03.04 13:55

4.3需要用只有6.0才有的新特性不得不加入v7 support的支持包

Mr_dsw
Mr_dsw   Ds   Rxr 2016.03.04 14:43

这个设置minSdk为11同样也会出现,貌似是默认的!著作权归作者所有。
Activity 发展到3.0(大概)之后,support v4 的出现时为了兼容以前的版本,这次是出现在support v7来支持,替代v4,就像以前在eclipse中创建
工程系统给我们自带v4包,现在是v7包

qq_20246723
qq_20246723   2016.03.04 19:02

这个设置minSdk为11同样也会出现,貌似是默认的!著作权归作者所有。
Activity 发展到3.0(大概)之后,support v4 的出现时为了兼容以前的版本,这次是出现在support v7来支持,替代v4,就像以前在eclipse中创建
工程系统给我们自带v4包,现在是v7包

Csdn user default icon
上传中...
上传图片
插入图片
准确详细的回答,更有利于被提问者采纳,从而获得C币。复制、灌水、广告等回答会被删除,是时候展现真正的技术了!