2 sherry142 sherry142 于 2016.03.09 16:17 提问

将安卓项目导入到eclipse,为什么所有内容都出现红叉叉?

代码应该没问题,就是导入后出现红叉。我是新人,eclipse也不知道安装好没。是不是没导入包什么的啊?
图片说明

9个回答

gao_chun
gao_chun   Rxr 2016.03.09 16:19

修改一下project.properties文件中的target,指定一个level再clean就可以了,例如:target=android-19

u013596119
u013596119   Rxr 2016.03.09 16:23

可能是没设置安卓sdk?为何不用android studio?

mars_0319
mars_0319   2016.03.09 16:24

环境问题,缺少基础的jar包

qq_17038573
qq_17038573   2016.03.09 16:39

看看你的安卓sdk是否设置成指定的level,然后clean一下工程再看看

csdn_java_wxy
csdn_java_wxy   2016.03.09 16:47

兄弟,别急啊,eclipse刚打开也是这样的,sdk要载入,如果一直是这样,那就看看你的sdk是不是有问题或者导入sdk有问题,工具不认识你这些包,工具的角度来说就是我不认识,请导包

huamanlou02
huamanlou02   2016.03.09 20:20

看下是不是jdk有问题,还是你导入的项目编码不一致或者版本不兼容,你可以去看看这个链接导入项目eclipse报错

qq_21912927
qq_21912927   2016.03.09 21:48

sdk版本的问题 因为谷歌现在官方推荐的开发工具是Android Studio 早已经抛弃了Eclipse 停止了对ADT的更新 前面好长时间我也在纠结这个问题 最后的结果是:
要么用Android Studio (本人也强烈推荐用这款开发工具,确实比Eclipse强很多) 如果偏要用Eclipse 那么新建工程的时候就要把最低版本设为4.0以上 就不会有问题 再者 如果你一定要用Eclipse 而且还要兼容低版本 那就找老版本的ADT插件 不过问题是老版本的ADT不支持最新API 如android6.0等

hou_weiyi
hou_weiyi   2016.03.10 10:47

哈哈哈哈,改下sdk api

lxk_1993
lxk_1993   Rxr 2016.03.11 08:52

楼上的都对 建议使用android studio

Csdn user default icon
上传中...
上传图片
插入图片