2 qq 34226779 qq_34226779 于 2016.03.09 16:39 提问

centos下 openstack yum无法安装dashboard

报错
Error: Package: python-django-openstack-auth-1.1.2-1.el6.noarch (openstack-havana)
Requires: Django14
Error: Package: python-django-appconf-0.5-3.el6.noarch (openstack-havana)
Requires: Django14
Error: Package: python-django-horizon-2013.2.3-1.el6.noarch (openstack-havana)
Requires: Django14
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

4个回答

oyljerry
oyljerry   Ds   Rxr 2016.03.09 21:09

依赖dfjango 你需要先安装好它

nihena8015
nihena8015 回复qq_34226779:yum install Django 跟这个好像没有关系,yum服务端不知道是不是有问题。在线下载安装按照常理不应该报错的,提示的那些包,服务器都上有。
接近 2 年之前 回复
qq_34226779
qq_34226779 装好好了 yum install Django 还是不行
接近 2 年之前 回复
nihena8015
nihena8015   2016.03.11 18:38

从昨天开始,我也报这个错误,不知道怎么解决。之前安装到这里都没有问题,不知道哪里限制了。就报错。从新安装也报错。
[root@openstack ~]# yum -y install openstack-dashboard
Loaded plugins: fastestmirror
Repository base is listed more than once in the configuration
Repository updates is listed more than once in the configuration
Repository extras is listed more than once in the configuration
Repository centosplus is listed more than once in the configuration
Repository contrib is listed more than once in the configuration
Loading mirror speeds from cached hostfile

  • base: mirrors.btte.net
  • epel: mirrors.opencas.cn
  • extras: mirrors.btte.net
  • rpmforge: mirrors.neusoft.edu.cn
  • updates: mirrors.opencas.cn Setting up Install Process Resolving Dependencies --> Running transaction check ---> Package openstack-dashboard.noarch 0:2013.2.3-1.el6 will be installed --> Processing Dependency: python-novaclient >= 2012.1 for package: openstack-dashboard-2013.2.3-1.el6.noarch --> Processing Dependency: python-keystoneclient >= 0.3.2 for package: openstack-dashboard-2013.2.3-1.el6.noarch --> Processing Dependency: python-django-openstack-auth >= 1.0.11 for package: openstack-dashboard-2013.2.3-1.el6.noarch --> Processing Dependency: python-django-horizon >= 2013.2.3 for package: openstack-dashboard-2013.2.3-1.el6.noarch --> Processing Dependency: python-django-compressor >= 1.3 for package: openstack-dashboard-2013.2.3-1.el6.noarch --> Processing Dependency: python-ceilometerclient >= 1.0.6 for package: openstack-dashboard-2013.2.3-1.el6.noarch --> Processing Dependency: python-troveclient for package: openstack-dashboard-2013.2.3-1.el6.noarch --> Processing Dependency: python-swiftclient for package: openstack-dashboard-2013.2.3-1.el6.noarch --> Processing Dependency: python-oslo-config for package: openstack-dashboard-2013.2.3-1.el6.noarch --> Processing Dependency: python-neutronclient for package: openstack-dashboard-2013.2.3-1.el6.noarch --> Processing Dependency: python-netaddr for package: openstack-dashboard-2013.2.3-1.el6.noarch --> Processing Dependency: python-heatclient for package: openstack-dashboard-2013.2.3-1.el6.noarch --> Processing Dependency: python-glanceclient for package: openstack-dashboard-2013.2.3-1.el6.noarch --> Processing Dependency: python-eventlet for package: openstack-dashboard-2013.2.3-1.el6.noarch --> Processing Dependency: python-django-appconf for package: openstack-dashboard-2013.2.3-1.el6.noarch --> Processing Dependency: python-cinderclient for package: openstack-dashboard-2013.2.3-1.el6.noarch --> Processing Dependency: mod_wsgi for package: openstack-dashboard-2013.2.3-1.el6.noarch --> Processing Dependency: httpd for package: openstack-dashboard-2013.2.3-1.el6.noarch --> Running transaction check ---> Package httpd.x86_64 0:2.2.15-47.el6.centos.3 will be installed --> Processing Dependency: httpd-tools = 2.2.15-47.el6.centos.3 for package: httpd-2.2.15-47.el6.centos.3.x86_64 --> Processing Dependency: apr-util-ldap for package: httpd-2.2.15-47.el6.centos.3.x86_64 --> Processing Dependency: /etc/mime.types for package: httpd-2.2.15-47.el6.centos.3.x86_64 --> Processing Dependency: libaprutil-1.so.0()(64bit) for package: httpd-2.2.15-47.el6.centos.3.x86_64 --> Processing Dependency: libapr-1.so.0()(64bit) for package: httpd-2.2.15-47.el6.centos.3.x86_64 ---> Package mod_wsgi.x86_64 0:3.2-7.el6 will be installed ---> Package python-ceilometerclient.noarch 0:1.0.8-1.el6 will be installed --> Processing Dependency: python-six for package: python-ceilometerclient-1.0.8-1.el6.noarch --> Processing Dependency: python-setuptools for package: python-ceilometerclient-1.0.8-1.el6.noarch --> Processing Dependency: python-prettytable for package: python-ceilometerclient-1.0.8-1.el6.noarch --> Processing Dependency: python-iso8601 for package: python-ceilometerclient-1.0.8-1.el6.noarch --> Processing Dependency: python-argparse for package: python-ceilometerclient-1.0.8-1.el6.noarch ---> Package python-cinderclient.noarch 0:1.0.7-2.el6 will be installed --> Processing Dependency: python-simplejson for package: python-cinderclient-1.0.7-2.el6.noarch --> Processing Dependency: python-requests for package: python-cinderclient-1.0.7-2.el6.noarch --> Processing Dependency: python-babel for package: python-cinderclient-1.0.7-2.el6.noarch ---> Package python-django-appconf.noarch 0:0.5-3.el6 will be installed --> Processing Dependency: Django14 for package: python-django-appconf-0.5-3.el6.noarch ---> Package python-django-compressor.noarch 0:1.3-2.el6 will be installed --> Processing Dependency: python-versiontools for package: python-django-compressor-1.3-2.el6.noarch --> Processing Dependency: Django for package: python-django-compressor-1.3-2.el6.noarch ---> Package python-django-horizon.noarch 0:2013.2.3-1.el6 will be installed --> Processing Dependency: pytz for package: python-django-horizon-2013.2.3-1.el6.noarch --> Processing Dependency: python-pbr for package: python-django-horizon-2013.2.3-1.el6.noarch --> Processing Dependency: python-lockfile for package: python-django-horizon-2013.2.3-1.el6.noarch --> Processing Dependency: python-dateutil for package: python-django-horizon-2013.2.3-1.el6.noarch --> Processing Dependency: Django14 for package: python-django-horizon-2013.2.3-1.el6.noarch ---> Package python-django-openstack-auth.noarch 0:1.1.2-1.el6 will be installed --> Processing Dependency: Django14 for package: python-django-openstack-auth-1.1.2-1.el6.noarch ---> Package python-eventlet.noarch 0:0.15.2-1.el6 will be installed --> Processing Dependency: python-greenlet for package: python-eventlet-0.15.2-1.el6.noarch ---> Package python-glanceclient.noarch 1:0.12.0-1.el6 will be installed --> Processing Dependency: python-warlock for package: 1:python-glanceclient-0.12.0-1.el6.noarch --> Processing Dependency: python-httplib2 for package: 1:python-glanceclient-0.12.0-1.el6.noarch --> Processing Dependency: pyOpenSSL for package: 1:python-glanceclient-0.12.0-1.el6.noarch ---> Package python-heatclient.noarch 0:0.2.6-2.el6 will be installed --> Processing Dependency: PyYAML for package: python-heatclient-0.2.6-2.el6.noarch ---> Package python-keystoneclient.noarch 1:0.7.1-2.el6 will be installed --> Processing Dependency: python-keyring for package: 1:python-keystoneclient-0.7.1-2.el6.noarch ---> Package python-netaddr.noarch 0:0.7.5-4.el6 will be installed ---> Package python-neutronclient.noarch 0:2.3.4-1.el6 will be installed --> Processing Dependency: python-cliff >= 1.0 for package: python-neutronclient-2.3.4-1.el6.noarch --> Processing Dependency: pyparsing for package: python-neutronclient-2.3.4-1.el6.noarch ---> Package python-novaclient.noarch 1:2.16.0-2.el6 will be installed ---> Package python-oslo-config.noarch 1:1.2.1-1.el6 will be installed ---> Package python-swiftclient.noarch 0:2.0.2-1.el6 will be installed ---> Package python-troveclient.noarch 0:0.1.4-3.el6 will be installed --> Running transaction check ---> Package apr.x86_64 0:1.3.9-5.el6_2 will be installed ---> Package apr-util.x86_64 0:1.3.9-3.el6_0.1 will be installed ---> Package apr-util-ldap.x86_64 0:1.3.9-3.el6_0.1 will be installed ---> Package httpd-tools.x86_64 0:2.2.15-47.el6.centos.3 will be installed ---> Package mailcap.noarch 0:2.1.31-2.el6 will be installed ---> Package pyOpenSSL.x86_64 0:0.13.1-2.el6 will be installed ---> Package python-argparse.noarch 0:1.2.1-2.1.el6 will be installed ---> Package python-babel.noarch 0:0.9.4-5.1.el6 will be installed ---> Package python-cliff.noarch 0:1.4.4-1.el6 will be installed --> Processing Dependency: python-cmd2 for package: python-cliff-1.4.4-1.el6.noarch ---> Package python-dateutil.noarch 0:1.4.1-6.el6 will be installed ---> Package python-django.noarch 0:1.3.1-1.el6.rf will be installed ---> Package python-django-appconf.noarch 0:0.5-3.el6 will be installed --> Processing Dependency: Django14 for package: python-django-appconf-0.5-3.el6.noarch ---> Package python-django-horizon.noarch 0:2013.2.3-1.el6 will be installed --> Processing Dependency: Django14 for package: python-django-horizon-2013.2.3-1.el6.noarch ---> Package python-django-openstack-auth.noarch 0:1.1.2-1.el6 will be installed --> Processing Dependency: Django14 for package: python-django-openstack-auth-1.1.2-1.el6.noarch ---> Package python-greenlet.x86_64 0:0.4.2-1.el6 will be installed ---> Package python-httplib2.noarch 0:0.7.7-1.el6 will be installed ---> Package python-iso8601.noarch 0:0.1.10-1.el6 will be installed ---> Package python-keyring.noarch 0:5.0-1.el6 will be installed ---> Package python-lockfile.noarch 0:0.8-3.el6 will be installed ---> Package python-pbr.noarch 0:0.8.0-1.el6 will be installed --> Processing Dependency: python-pip for package: python-pbr-0.8.0-1.el6.noarch ---> Package python-prettytable.noarch 0:0.7.2-1.el6.centos will be installed ---> Package python-pyparsing.noarch 0:1.5.6-2.el6.rf will be installed ---> Package python-requests.noarch 0:2.6.0-3.el6 will be installed --> Processing Dependency: python-urllib3 >= 1.10.2-1 for package: python-requests-2.6.0-3.el6.noarch --> Processing Dependency: python-ordereddict >= 1.1 for package: python-requests-2.6.0-3.el6.noarch --> Processing Dependency: python-chardet >= 2.2.1-1 for package: python-requests-2.6.0-3.el6.noarch ---> Package python-setuptools.noarch 0:0.6.10-3.el6 will be installed ---> Package python-simplejson.x86_64 0:2.0.9-3.1.el6 will be installed ---> Package python-six.noarch 0:1.9.0-2.el6 will be installed ---> Package python-versiontools.noarch 0:1.9.1-3.el6 will be installed ---> Package python-warlock.noarch 0:1.0.1-1.el6 will be installed --> Processing Dependency: python-jsonschema for package: python-warlock-1.0.1-1.el6.noarch --> Processing Dependency: python-jsonpatch for package: python-warlock-1.0.1-1.el6.noarch ---> Package python-yaml.x86_64 0:3.09-3.el6.rf will be installed ---> Package pytz.noarch 0:2010h-2.el6 will be installed --> Running transaction check ---> Package python-chardet.noarch 0:2.2.1-1.el6 will be installed ---> Package python-cmd2.noarch 0:0.6.4-7.el6 will be installed ---> Package python-django-appconf.noarch 0:0.5-3.el6 will be installed --> Processing Dependency: Django14 for package: python-django-appconf-0.5-3.el6.noarch ---> Package python-django-horizon.noarch 0:2013.2.3-1.el6 will be installed --> Processing Dependency: Django14 for package: python-django-horizon-2013.2.3-1.el6.noarch ---> Package python-django-openstack-auth.noarch 0:1.1.2-1.el6 will be installed --> Processing Dependency: Django14 for package: python-django-openstack-auth-1.1.2-1.el6.noarch ---> Package python-jsonpatch.noarch 0:1.2-2.el6.centos will be installed --> Processing Dependency: python-jsonpointer for package: python-jsonpatch-1.2-2.el6.centos.noarch ---> Package python-jsonschema.noarch 0:2.3.0-1.el6 will be installed ---> Package python-libs.x86_64 0:2.6.6-51.el6 will be updated --> Processing Dependency: python-libs(x86-64) = 2.6.6-51.el6 for package: python-2.6.6-51.el6.x86_64 ---> Package python-libs.x86_64 0:2.6.6-64.el6 will be an update ---> Package python-pip.noarch 0:7.1.0-1.el6 will be installed ---> Package python-urllib3.noarch 0:1.10.2-1.el6 will be installed --> Processing Dependency: python-backports-ssl_match_hostname for package: python-urllib3-1.10.2-1.el6.noarch --> Running transaction check ---> Package python.x86_64 0:2.6.6-51.el6 will be updated ---> Package python.x86_64 0:2.6.6-64.el6 will be an update ---> Package python-backports-ssl_match_hostname.noarch 0:3.4.0.2-4.el6.centos will be installed --> Processing Dependency: python-backports for package: python-backports-ssl_match_hostname-3.4.0.2-4.el6.centos.noarch ---> Package python-django-appconf.noarch 0:0.5-3.el6 will be installed --> Processing Dependency: Django14 for package: python-django-appconf-0.5-3.el6.noarch ---> Package python-django-horizon.noarch 0:2013.2.3-1.el6 will be installed --> Processing Dependency: Django14 for package: python-django-horizon-2013.2.3-1.el6.noarch ---> Package python-django-openstack-auth.noarch 0:1.1.2-1.el6 will be installed --> Processing Dependency: Django14 for package: python-django-openstack-auth-1.1.2-1.el6.noarch ---> Package python-jsonpointer.noarch 0:1.0-3.el6.centos will be installed --> Running transaction check ---> Package python-backports.x86_64 0:1.0-5.el6 will be installed ---> Package python-django-appconf.noarch 0:0.5-3.el6 will be installed --> Processing Dependency: Django14 for package: python-django-appconf-0.5-3.el6.noarch ---> Package python-django-horizon.noarch 0:2013.2.3-1.el6 will be installed --> Processing Dependency: Django14 for package: python-django-horizon-2013.2.3-1.el6.noarch ---> Package python-django-openstack-auth.noarch 0:1.1.2-1.el6 will be installed --> Processing Dependency: Django14 for package: python-django-openstack-auth-1.1.2-1.el6.noarch --> Finished Dependency Resolution Error: Package: python-django-openstack-auth-1.1.2-1.el6.noarch (openstack-havana) Requires: Django14 Error: Package: python-django-appconf-0.5-3.el6.noarch (openstack-havana) Requires: Django14 Error: Package: python-django-horizon-2013.2.3-1.el6.noarch (openstack-havana) Requires: Django14 You could try using --skip-broken to work around the problem You could try running: rpm -Va --nofiles --nodigest [root@openstack ~]# yum -y install openstack-dashboard
nihena8015
nihena8015   2016.03.11 18:40

--> Finished Dependency Resolution
Error: Package: python-django-openstack-auth-1.1.2-1.el6.noarch (openstack-havana)
Requires: Django14
Error: Package: python-django-appconf-0.5-3.el6.noarch (openstack-havana)
Requires: Django14
Error: Package: python-django-horizon-2013.2.3-1.el6.noarch (openstack-havana)
Requires: Django14
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

nihena8015
nihena8015 回复qq_34226779: 没有解决,yum update 更新后,安装也报这个错误,不知道什么原因。3月初我安装的时候没有任何问题,在10号后安装就报这个错误。
接近 2 年之前 回复
qq_34226779
qq_34226779 你解决了吗
接近 2 年之前 回复
sijingyang
sijingyang   2016.03.14 10:04

我也遇到了,感觉是yum源的问题,谁有本地yum源可以试试。

Csdn user default icon
上传中...
上传图片
插入图片
准确详细的回答,更有利于被提问者采纳,从而获得C币。复制、灌水、广告等回答会被删除,是时候展现真正的技术了!