明知道这是一场意外 2016-03-23 05:03 采纳率: 66.7%
浏览 1470
已采纳

刷ACM的小伙伴进uva oj 455 Periodic Strings,求大神指出我的问题

Periodic Strings
A character string is said to have period k if it can be formed by concatenating one or more repetitions of another string of length k. For example, the string "abcabcabcabc" has period 3, since it is formed by 4 repetitions of the string "abc". It also has periods 6 (two repetitions of "abcabc") and 12 (one repetition of "abcabcabcabc").

Write a program to read a character string and determine its smallest period.

Input

The first line oif the input file will contain a single integer N indicating how many test case that your program will test followed by a blank line. Each test case will contain a single character string of up to 80 non-blank characters. Two consecutive input will separated by a blank line.

Output

An integer denoting the smallest period of the input string for each input. Two consecutive output are separated by a blank line.

Sample Input

1

HoHoHo
Sample Output

2

简单说就是输入一个长度不超过80个字符串,输出其最小周期(注意题目有关空行的格式问题) 我WA了五次,渣渣被虐哭囧

下面的是我的代码,求给出反例或指出我的逻辑错误,谢谢

 //要多注意细节,多考虑极端情况(注意循环字符中还有相同字符的情况!!!)
#include <stdio.h>
#include <string.h>
int main()
{
    int T,len,i,k,temp,first=1;//T代表测试块的个数,len是字符串长度,temp存储可能的周期值
    char str[90]={0};//存储字符串
    scanf("%d",&T);
    while(T--){
        temp=0,k=0;
        scanf("%s",str);
        len=strlen(str);
        for(i=1;i<len;i++){
            if(str[i]==str[0]){
                temp=i;
                for(k=0;k<temp;k++,i++){
                    if(str[k]!=str[i]){//反向思维,针对ABABACC的情况
                        temp=0;
                        i--;
                        break;
                    }
                    if(k!=temp-1&&i==len-1){//主要针对ABCDAB的情况
                        temp=0;
                        break;
                    }
                    if((k==temp-1)&&(i!=len-1))
                        k=-1;//始终注意k的自加
                }
            }
        }
        if(i==len&&!k)//注意不存在周期的情况!
            temp=0;
        if(first){
            printf("%d\n",temp);
            first=0;
        }
        else
            printf("\n%d\n",temp);
    }
    return 0;
}

  • 写回答

1条回答

  • 林深 2016-03-23 05:50
    关注

    反例:
    输入: abc
    正确输出:3
    错误输出:0

    本回答被题主选为最佳回答 , 对您是否有帮助呢?
    评论

报告相同问题?

悬赏问题

  • ¥20 怎么在stm32门禁成品上增加记录功能
  • ¥15 Source insight编写代码后使用CCS5.2版本import之后,代码跳到注释行里面
  • ¥50 NT4.0系统 STOP:0X0000007B
  • ¥15 想问一下stata17中这段代码哪里有问题呀
  • ¥15 flink cdc无法实时同步mysql数据
  • ¥100 有人会搭建GPT-J-6B框架吗?有偿
  • ¥15 求差集那个函数有问题,有无佬可以解决
  • ¥15 【提问】基于Invest的水源涵养
  • ¥20 微信网友居然可以通过vx号找到我绑的手机号
  • ¥15 解riccati方程组