2 superdbg1 SuperDBG1 于 2016.03.25 18:05 提问

在ubuntu上使用最新版本的bluez 进行蓝牙4.0的通信

小弟 目前使用的ubuntu的内核版本为4.2.0 也已经按照网上的教程安装了最新的bluez
问题1:

但是查看bluez的版本时 ,还是原来电脑上的4. 多版本 ,不是5. 多版本

问题2

使用
hcitool lescan
LE Scan …
12:88:FF:FF:11:99 touch
12:88:FF:FF:11:99 (unknown)

可以搜索到设备但就是连接不到设备

但是利用gattool 去连接时 gatttool -b 00:17:EA:93:95:89 -I

显示结果为:
connect error:Transport endpoint is not connected (107)

个人怀疑 问题是后来安装的bluez没有替换原来的bluez

请各位大神指教 谁有成功的经验 告知小弟 不胜感激 邮箱 linux_dbg@163.com

2个回答

Nurke
Nurke   2017.07.27 16:52

恩啊,我也出现了这个问题,请问楼主怎样把原来的bluez4.1删掉的

Nurke
Nurke   2017.08.01 13:30

我知道了,在编译目录下也有可执行文件,你把这些原本的可执行文件(hcitool等)用编译目录下的可执行文件替换掉,版本就正确了

Csdn user default icon
上传中...
上传图片
插入图片
准确详细的回答,更有利于被提问者采纳,从而获得C币。复制、灌水、广告等回答会被删除,是时候展现真正的技术了!