2 qq 28745795 qq_28745795 于 2016.03.28 11:44 提问

自定义的Frament不能使用

代码如图
报错类型如图
Logcat提示,Fragment1是我自定义的Fragment类,继承自Fragment

4个回答

dongfeng9ge
dongfeng9ge   Ds   Rxr 2016.03.28 11:53

求Fragment1的源码

qq_28745795
qq_28745795   2016.03.28 12:00

啊。。。幸亏东风9哥提醒,我查看了一下Fragment1源码发现导入包是import android.support.v4.app.Fragment; 。。。难怪这里会不兼容,汗,,,,,
修改了一下,可以跑起来了。解决方法贴上来供后来者参考:
android.support.v4.app.FragmentManager fragmentManager=getSupportFragmentManager();
android.support.v4.app.FragmentTransaction fragmentTransaction=fragmentManager.beginTransaction();
fragmentTransaction.replace(android.R.id.content,new Fragment1());

lxk_1993
lxk_1993   Rxr 2016.03.28 13:20

fragment 包名不对吧

crazy1235
crazy1235   Ds   Rxr 2016.03.29 10:29
Csdn user default icon
上传中...
上传图片
插入图片
准确详细的回答,更有利于被提问者采纳,从而获得C币。复制、灌水、广告等回答会被删除,是时候展现真正的技术了!