2 wu88299 wu88299 于 2016.04.15 10:29 提问

Android:minsdkversion 设置越低越好吗

minsdkversion 设置多少合适呢。 如果只影响兼容的最低版本,是不是越低越好呢?如
果不是,什么原因呢,谢谢各位!

4个回答

u010853217
u010853217   2016.04.15 11:35

当然不是越低越好,一般来说都是根据市场占有率来决定,正常情况向下兼容到2.3左右就足够了,更低的话,有些API无法使用,太高的话,会流失一些用户,
当然了,还有适配的问题要做好,兼容的版本越多,就要考虑到更多的适配问题,有些低版本的安卓,还带物理键盘的,而且手机屏幕很小,这些因素你都需要考虑到的

lxk_1993
lxk_1993   Rxr 2016.04.15 13:48

现在一般 min 14就好了吧 还有人用4.0以下的系统?

Wei_Smile
Wei_Smile   2016.04.15 14:50

并不是越小越好,你可以看看现在市场上各个版本的市场占有率,现在一般最小都是设14,上限设19或者更大,这个设置是要匹配市场的,现在市场上已经
大部分都是4.0的设备的

SEU_Calvin
SEU_Calvin   2016.10.30 19:34

设置低了能提高适用率,但是你要保证代码里调用的系统API必须在min以上,不然会出错的。

Csdn user default icon
上传中...
上传图片
插入图片
准确详细的回答,更有利于被提问者采纳,从而获得C币。复制、灌水、广告等回答会被删除,是时候展现真正的技术了!