2 woshiwoxingfu woshiwoxingfu 于 2012.09.10 09:57 提问

如何给Android4.0创建AVD?

Android4.0早就发布了。我已经更新了我的ADT插件,而且也下载了4.0版本的SDK。但是当我试图给Android4.0创建AVD的时候,Eclipse提示我‘Unable to find a 'userdata.img' file for ABI armeabi to copy into the AVD folder'’。
我发现d:\android-sdk-windows\platforms\android-14 中没有images文件夹,但是其他版本中有。这个文件夹中应该有创建AVD所需要的‘userdata.img’这个文件。我应该在哪得到‘userdata.img’文件,而且我应该怎么给Android4.0创建AVD?

9个回答

niangzhi
niangzhi   2012.09.10 10:28
已采纳

我也是这样做的。如果你在“Android4.0(API 14)”的章节中看到“Android SDK Manager”,那么你将看到一些包。其中有一个的名字是“ARM EABI v7a System Image”。
这就是你为了创建一个Android4.0虚拟机需要下载的。
enter image description here

eagleyan
eagleyan popcorn 是对的
大约 3 年之前 回复
woshiwoxingfu
woshiwoxingfu 可以了,3Q
5 年多之前 回复
popcorn
popcorn   2012.09.21 23:40

我也遇到过这个问题,显示ARM EABI v7a System Image已经安装了,但是仍然提示这个错误.我就把ARM EABI v7a System Image删除掉然后重新再安装一下就好了.

eagleyan
eagleyan popcorn 是对的
大约 3 年之前 回复
yiranwujixian
yiranwujixian 哈哈,这个办法真好用。
大约 5 年之前 回复
Lotuslovenature
Lotuslovenature   2013.09.05 15:33

4.0以后sdk目录发生了变化,用sdk manager更新arm eabi v7a system image
就会在sdk目录system-images下面出现下载下来的image文件。以前2.x的时候是在platforms里面

yizhenbeifeng
yizhenbeifeng   2012.09.10 10:38

如果你仍然没有解决这个问题,这个网站Android Create AVD 显示你怎么在Eclipse中安装最新版本的Android SDK和AVD4.0版本,并且有视频和截图的说明。

cuijinquan
cuijinquan   2012.11.07 23:37

如果上面仁兄的回答不能解决的话,检查下目录,有时会遇到文件夹带空格或中文,创建avd就会报错.

u013534446
u013534446 回复woshiwoxingfu: 对
2 年多之前 回复
woshiwoxingfu
woshiwoxingfu 已经按照第一个答案解决了。还是谢谢你,以后再遇到这个问题的可能也会有用
大约 5 年之前 回复
CODER_V
CODER_V   2016.08.17 13:47

如果上面仁兄的回答不能解决的话,检查下目录,有时会遇到文件夹带空格或中文,创建avd就会报错.

oSanYeCao1234567
oSanYeCao1234567   Ds   Rxr 2016.10.02 11:46

先需要下载4.0的系统镜像

u1254z62
u1254z62   2017.01.03 18:10

先需要下载4.0的系统镜像

qq_40885478
qq_40885478   2017.11.01 14:46

4.0以后sdk目录发生了变化,用sdk manager更新arm eabi v7a system image
就会在sdk目录system-images下面出现下载下来的image文件。以前2.x的时候是在platforms里面

Csdn user default icon
上传中...
上传图片
插入图片
准确详细的回答,更有利于被提问者采纳,从而获得C币。复制、灌水、广告等回答会被删除,是时候展现真正的技术了!