2 a993610942 a993610942 于 2016.04.20 18:41 提问

jdk1.8.0_60无法连接Access

图片说明
我的jdk版本是1.8.0_60,连接Access数据库出现sun.jdbc.odbc.JdbcOdbcDriver
No suitable driver found for jdbc:odbc:Driver={MicroSoft Access Driver (*.mdb)};DBQ=TestDB.mdb。
图片说明
我的eclipse版本是4.5.1 这种写法在另一台jdk1.6上的电脑上不会显示找不到数据库文件图片说明

8个回答

a993610942
a993610942   2016.04.20 18:46

数据库是放在同目录文件下的

a993610942
a993610942   2016.04.20 19:10

图片说明
这是!!! 导入了Access_JDBC.jar 导入成api

a993610942
a993610942   2016.04.20 18:46

数据库是放在同目录文件下的

a993610942
a993610942   2016.04.20 19:09

图片说明
这是!!! 导入了Access_JDBC.jar 导入成api

a993610942
a993610942   2016.04.20 19:11

图片说明
这是!!! 导入了Access_JDBC.jar 导入成api

WwwRuiOP
WwwRuiOP   2016.05.31 20:19

但是如何导入了Access__JDBC.jar 导入成api啊?我的没有这个jar包,而且也显示的是一样的问题

WwwRuiOP
WwwRuiOP   2016.06.01 14:33

图片说明
导入了Access__JDBC.jar包后可以这样使用就不会出错了

hongfu8
hongfu8   2016.11.19 14:05

The JDBC-ODBC Bridge should be considered a transitional solution; it will be removed in JDK 8. In addition, Oracle does not support the JDBC-ODBC Bridge. Oracle recommends that you use JDBC drivers provided by the vendor of your database instead of the JDBC-ODBC Bridge.
官网上JDK1。8已经不支持了,需要自己加驱动了

Csdn user default icon
上传中...
上传图片
插入图片
准确详细的回答,更有利于被提问者采纳,从而获得C币。复制、灌水、广告等回答会被删除,是时候展现真正的技术了!