2 u014559683 u014559683 于 2016.04.26 17:23 提问

侧滑menu SlidingMenu第三方库兼容问题
本人在做一个android练习,把acrionBarsherlock跟SlidingMenu生成的jar包复制到lib,加入项目,但是我的main Activity一旦继承SlidingFragmentMenu就运行报错。不继承就正常。求各位哥哥姐姐指点!

6个回答

u013147734
u013147734   2016.04.26 17:29

报什么错呢?贴log

u014559683
u014559683   2016.04.26 17:49

图片说明

u014559683
u014559683   2016.04.26 17:50

请问是我的库有问题吗?

u014559683
u014559683   2016.04.26 17:53

我之前把三个库都当做is libaary加到我的项目中,但是现实有3个v4包eclipse无法分辨。我不知道怎么做只能把他们生成的jar包复制到我的项目里加上去。但是我的main activity本来是继承FragmentActivity ,改成slidingFragmentActivity就运行报错。是我的库有问题吗?

u014559683
u014559683   2016.04.26 17:55

还有那个报3个v4包的问题请问怎么解决,我看视频操作,跟着视频一起做,他不报错我却报错了,是我的eclipse版本太低了吗?

sinat_25404831
sinat_25404831   2016.04.27 17:26

这东西已经很少用了啊 学学DrawerLayout吧 毕竟官方提供的 代替SlidingMenu的 要简单很多的

u014559683
u014559683 谢谢,有空我去了解下。
一年多之前 回复
Csdn user default icon
上传中...
上传图片
插入图片
准确详细的回答,更有利于被提问者采纳,从而获得C币。复制、灌水、广告等回答会被删除,是时候展现真正的技术了!