2 beardedj BeardedJ 于 2013.09.18 21:10 提问

fedora安装mysql出现版本冲突有什么解决办法

在fedora15中用yum安装mysql,可能之前不太懂就把mysql-libs给更新了,然后问题就来了,如下:
错误:Package: mysql-5.5.23-1.fc15.i686 (updates)
Requires: mysql-libs(x86-32) = 5.5.23-1.fc15
已安装: mysql-libs-5.5.24-1.fc15.i686 (@updates-testing)
mysql-libs(x86-32) = 5.5.24-1.fc15
Available: mysql-libs-5.5.10-2.fc15.i686 (fedora)
mysql-libs(x86-32) = 5.5.10-2.fc15
Available: mysql-libs-5.5.23-1.fc15.i686 (updates)
mysql-libs(x86-32) = 5.5.23-1.fc15
mysql和mysql-server的版本和mysql-libs的版本对不上了,出现了问题,我本想卸载mysql-libs包,然后再安装正确版本,但是mysql-libs这个包依赖链太深,一时也卸载不了,所以有没有什么其他办法可以解决这个问题么

Csdn user default icon
上传中...
上传图片
插入图片
准确详细的回答,更有利于被提问者采纳,从而获得C币。复制、灌水、广告等回答会被删除,是时候展现真正的技术了!