2 doublee hcz DoubleE_hcz 于 2016.09.06 18:41 提问

也不知道那位大神能帮我解决一下,关于易语言的,我今天也是刚弄。

我没有币了所以没法悬赏了

 .版本 2
.支持库 iext

.子程序 _按钮2_被单击
.局部变量 表项, 整数型
.局部变量 计数, 整数型

打开 (“F:\学习文件夹\E\会员表.edb”, , , , , , )
信息框 (“数据库启动”, 0, , )

.计次循环首 (取记录数 (), 计数)
    跳过 (计数)
    表项 = 超级列表框1.插入表项 (, , , , , )
    超级列表框1.置标题 (表项, 0, 读 (“姓名”))
    超级列表框1.置标题 (表项, 1, 读 (“密码”))
.计次循环尾 ()

.子程序 _窗口2_创建完毕

超级列表框1.插入列 (, “姓名”, 80, , , )
超级列表框1.插入列 (, “密码”, 80, , , )

上面是代码

下面是运行结果

图片说明

#在下面是数据库

图片说明

为什么在超级列表框中只显示1条记录

2个回答

caozhy
caozhy   Ds   Rxr 2016.09.07 00:10
已采纳

http://blog.sina.com.cn/s/blog_6a5cddf60102vopd.html
你缺少 记录集.到下一条 ()

DoubleE_hcz
DoubleE_hcz 非常感谢你,我看了你那个微博,我不是链接的外部数据库,但是给了我启发,其实就是我的数据库记录数不明确,
一年多之前 回复
DoubleE_hcz
DoubleE_hcz   2016.09.07 09:16
 .版本 2
.支持库 iext

.判断循环首 (尾记录后 () = 假)
    超级列表框1.插入表项 (, , , , , )
    超级列表框1.置标题 (超级列表框1.取表项数 () - 1, 0, 读 (#姓名))
    超级列表框1.置标题 (超级列表框1.取表项数 () - 1, 1, 读 (#密码))
    跳过 ()

.判断循环尾 ()

以上代码可以实现,数据库在超级列表框全部显示取来,希望给大家一些经验。

运行结果↓

图片说明

Csdn user default icon
上传中...
上传图片
插入图片
准确详细的回答,更有利于被提问者采纳,从而获得C币。复制、灌水、广告等回答会被删除,是时候展现真正的技术了!