2 weixin 36082302 weixin_36082302 于 2016.09.08 09:56 提问

编译除本机内核版本之外的其他内核版本的驱动

请教各位大神:
我的电脑内核是3.11的,但是编译到板子的内核是2.6的,所以想编译生成2.6版本的ko文件,编译成功了,但是加载时还是说版本不匹配
OscPcie: disagrees about version of symbol module_layout

insmod: error inserting 'OscPcie.ko': -1 Invalid module format
如何解决呢?

1个回答

dabocaiqq
dabocaiqq   2016.11.16 01:53
Csdn user default icon
上传中...
上传图片
插入图片
准确详细的回答,更有利于被提问者采纳,从而获得C币。复制、灌水、广告等回答会被删除,是时候展现真正的技术了!