2 liangzi321321 liangzi321321 于 2016.09.08 22:37 提问

myeclipse10创建的web项目配置上struts2以后就会报错

图片说明如图,我的是myeclipse10,tomcat7,jdk1.6,但是就是给我报这个错,百度以后说是低版本的JVM不兼容高版本的class,但是我的jdk不能换,因为公司需要,而我想美事做做小程序玩玩,结果刚配置,就这样了,struts2 2.5版本和2.1版本都不行,求解答啊

3个回答

devmiao
devmiao   Ds   Rxr 2016.09.08 23:58
u013829202
u013829202   Rxr 2016.09.09 15:57

你的配置有问题。先检查支持的包是不是加全了。 然后检查web.xml和struts.xml。

struts.xml


/index.jsp
/login.jsp

web.xml:
 <filter>
<filter-name>struts2</filter-name>
<filter-class>org.apache.struts2.dispatcher.ng.filter.StrutsPrepareAndExecuteFilter</filter-class>



struts2
/*

liangzi321321
liangzi321321   2016.09.18 15:20

谢谢楼上两位,不过不是那样的,我的配置没有问题,我又重新安装了一个jdk1.7,电脑以前公司用的是1.6,然后装完1.7就好了,我现在是两个jdk来回切换用呢

Csdn user default icon
上传中...
上传图片
插入图片