2 wengsy 5041 wengsy_5041 于 2016.09.22 08:36 提问

extjs3.0和IE11不兼容怎么办

使用extjs和IE11的时候不兼容,兼容模式下可以运行。但是其他页面会因为兼容模式出错,所以想找个方法在不兼容的模式下通过改代码解决该问题。

2个回答

u013829202
u013829202   Rxr 2016.09.22 09:28
已采纳

应该是extjs语法有问题。Ie不承认你这种语法。 你可以用ie调试,看有没有黄色感叹号,如果看不出来,用ie8试试。会明显一点

showbo
showbo   Ds   Rxr 2016.09.22 14:01

导入ext-all-debug.js,F12看浏览器报什么错误

报错了的话压缩过的无法修改源代码。

或者用meta X-UA-Compatible指定以ie8来运行

 <meta http-equiv="X-UA-Compatible" content="IE=8">
Csdn user default icon
上传中...
上传图片
插入图片