2 shuang1994 shuang1994 于 2017.04.21 15:09 提问

ubuntu16.04下编译android4.0.3出现的问题 5C

make: ***[out/host/linux-x86/obj/EXECUTABLES/aapt_intermediates/appt] 错误 1

解决方法:

打开Android.mk文件

$gedit frameworks/base/tools/aapt/Android.mk

编辑下面一行:

ifeq ($(HOST_OS),linux)

#LOCAL_LDLIBS += -lrt       把这行注释掉,改为下面一行。

LOCAL_LDLIBS += -lrt -lpthread

endif

按照这个方法还是不能解决怎么办?我的报错是/home/chen/Android/TI-Android-ICS-4.0.3-DevKit-EVM-SK-3.0.1/TI_Andorid_ICS_4.0.3_AM335x_Sources/TI-Android-ICS-4.0.3-DevKit-EVM-SK-3.0.1/frameworks/base/tools/aapt/XMLNode.cpp:207:对‘pseudolocalize_string(std::basic_string, std::allocator > const&)’未定义的引用
collect2: ld returned 1 exit status
make: *** [out/host/linux-x86/obj/EXECUTABLES/aapt_intermediates/aapt] 错误 1

2个回答

shen_wei
shen_wei   Ds   Rxr 2017.04.21 15:32

http://blog.chinaunix.net/uid-29287950-id-3984594.html

 错误(4):
/usr/bin/ld: cannot find -lz
 collect2: ld returned 1 exit status
 make: *** [out/host/linux-x86/obj/EXECUTABLES/aapt_intermediates/aapt] Error 1

解决:
sudo apt-get install lib32z1-dev
shuang1994
shuang1994 搭建环境的时候就安装了这个包,输入你的命令后显示这样:lib32z1-dev 已经是最新版 (1:1.2.8.dfsg-2ubuntu4.1)。
大约一个月之前 回复
shuang1994
shuang1994   2017.04.23 22:58

sudo apt-get install lib64z1-dev成功解决

Csdn user default icon
上传中...
上传图片
插入图片