2 jerryliun jerryliun 于 2017.08.28 14:00 提问

sequoiaDb 2.6 对应的PHP驱动无法使用

PHP Warning: PHP Startup: Unable to load dynamic library '/usr/local/php/lib/php/extensions/no-debug-non-zts-20121212/libsdbphp.5.5.0.so' - /usr/local/php/lib/php/extensions/no-debug-non-zts-20121212/libsdbphp.5.5.0.so: cannot open shared object file: No such file or directory in Unknown on line 0

报文件或目录不存在。
PHP版本HP 5.5.38

如上报错问题如何解决?
php5.6.x的驱动何时能出来?

1个回答

SequoiaDB_Official
SequoiaDB_Official   2017.08.28 14:01
已采纳

cd 到php目录,然后执行 ./php -d extension= -m 看看又没有SequoiaDB模块。
具体操作如下:

cd /opt/sequoiadb/tools/server/php/bin/

./php -d extension=/opt/sequoiadb/lib/phplib/libsdbphp-5.4.6.so -m

执行返回:
[PHP Modules]
Core
ctype
date
dom
ereg
fileinfo
filter
hash
iconv
json
libxml
pcre
PDO
pdo_sqlite
Phar
posix
Reflection
Sequoiadb
session
SimpleXML
SPL
sqlite3
standard
tokenizer
xml
xmlreader
xmlwriter
[Zend Modules]

如果能正常加载SequoiaDB模块,说明版本是兼容的,那么要检查php.ini的配置是否正确配置,如果php.ini没问题,检查php是否有正确加载这个路径的php.ini,apache + php的情况,经常是没有加载php自己的php.ini,而是加载了apache的php.ini
另:目前支持的PHP最高版本是5.5,5.6可以在后续版本加入,具体时间暂不确定。

Csdn user default icon
上传中...
上传图片
插入图片