2 qq 23153607 qq_23153607 于 2017.09.07 14:11 提问

Tomcat部署项目特别慢,在登录后使用,加载页面也特别慢 1C

是这样的,我在本地用ecplice,启用Tomcat运行项目正常。
但是打成war包,放在本地的Tomcat下,startup.bat.项目启动的特别慢,而且使用过程中加载页面也特别的慢!

6个回答

loowooowool
loowooowool   2017.09.07 15:01

这个问题有点让人无从下手,你war包连接的数据库只要和编译器里面的一样,应该效果一样才对,编译war的时候最好也把test的内容忽略

qq_23153607
qq_23153607 我也感觉不应该呀!忽略了,还是不行。
3 个月之前 回复
qq_28656797
qq_28656797   2017.09.07 15:09

tomcat有些东西可能是你用不到的,把它删了可以节约很多资源

qq_23153607
qq_23153607 我新下载的Tomcat,里面没什么东西。
3 个月之前 回复
Small_Mouse0
Small_Mouse0   Ds   Rxr 2017.09.07 15:42

不应该呀,,,eclipse运行和放本地一样的,,,你看看tomcat的webapp目录下是不是很多jar/war

哎或者是机子问题,,,重启一下再试试

Small_Mouse0
Small_Mouse0 回复qq_23153607: 换个新的如何??还是老毛病?
3 个月之前 回复
qq_23153607
qq_23153607 我也感觉不应该呀!Tomcat我重新下载了一个,然后打包放进去的,机子没问题。
3 个月之前 回复
dcxy0
dcxy0   Ds   Rxr 2017.09.07 16:40

看下启动日志,还有访问日志那些,看看日志里面是不是有执行了什么耗时操作。

dcxy0
dcxy0 回复qq_23153607: 你把eclipse下面的Servers里面的server.xml,content.xml这几个配置文件,都复制到你本地的tomcat里面去,然后启动试试。
2 个月之前 回复
dcxy0
dcxy0 回复qq_23153607: 项目里面都用了什么?还是服务器的配置很低?
2 个月之前 回复
qq_23153607
qq_23153607 我看了下日志,Deployment of web application directory 路径 has finished in 104,445 ms,时间最长的就这个了,说的把这个项目部署时间104秒。
3 个月之前 回复
qq_31754085
qq_31754085   2017.09.07 16:46

这个有可能是tomcat 配置问题 ,你在eclipse中启动tomcat 是走的eclipse中tomcat的配置,而你直接使用tomcat启动会走tomcat自己的配置

qq_23153607
qq_23153607 回复IT迷你白: 是的,我配置的都一样。
3 个月之前 回复
qq_31754085
qq_31754085 如果你没设置过tomcat的bin目录下的配置文件,初始化的内存空间和Perm空间都很小 ,有可能会卡,甚至出现溢出
3 个月之前 回复
sphinx0906
sphinx0906   2017.09.07 17:36

个人觉得肯定是首次运行加载的问题,,还有就是你启动tomcat的时候把相关的配置度设置好了吗,,,你应该在配置文件里面更改一下内存空间,,这样效果很显著

qq_23153607
qq_23153607 改了,还是不行。
3 个月之前 回复
Csdn user default icon
上传中...
上传图片
插入图片