2 u011781616 u011781616 于 2017.09.15 10:24 提问

java compiler没有1.8

java compiler没有1.8 怎么解决呢,项目每次都打错,感觉很不舒服,我现在用的是jdk1.8,但是project facts 最大只能选择1.7。 哪位大侠知道怎么修改的 ????

3个回答

u011293970
u011293970   2017.09.15 10:26

你用的什么编译器,是myeclipse 还是什么?如果是myeclipse 看看是不是你的版本有点低

u011781616
u011781616 eclipse
2 个月之前 回复
danee1
danee1   2017.09.15 10:27

你说的是 eclipse?图片说明

如果你的 eclipse版本低 可能就没有对应的 编译器了

danee1
danee1 回复卓成俊: 那就是你的 eclipse 的版本低了,下个新版本的eclipse 就行。说白了 就是 你用的那版本eclipse 开发的时候 还没有jdk8呢,人家怎么支持未来出现的产品?
2 个月之前 回复
u011781616
u011781616 对 就是这里 只有1.7 我在想是在哪里配置的?
2 个月之前 回复
qq_40236912
qq_40236912   2017.09.15 11:18

目前没有,1.7就已经够牛逼的了

u011781616
u011781616 但是我的JDK是1.8 所以总是报错,其实项目还是能跑起来,就是看着打杀杀飘红很不舒服
2 个月之前 回复
Csdn user default icon
上传中...
上传图片
插入图片