2 shenchengwoshi shenchengwoshi 于 2017.09.18 14:16 提问

ssh框架问题,求大神帮忙看看 20C
 2017-09-18 14:06:13,302 [localhost-startStop-1] ERROR org.springframework.web.context.ContextLoader - Context initialization failed
org.springframework.beans.factory.BeanDefinitionStoreException: Failed to read candidate component class: URL [jar:file:/C:/Program%20Files/Java/jre7/lib/ext/dns_sd.jar!/com/apple/dnssd/AppleBrowser.class]; nested exception is org.springframework.core.NestedIOException: ASM ClassReader failed to parse class file - probably due to a new Java class file version that isn't supported yet: URL [jar:file:/C:/Program%20Files/Java/jre7/lib/ext/dns_sd.jar!/com/apple/dnssd/AppleBrowser.class]; nested exception is java.lang.IllegalArgumentException

……
Caused by: org.springframework.core.NestedIOException: ASM ClassReader failed to parse class file - probably due to a new Java class file version that isn't supported yet: URL [jar:file:/C:/Program%20Files/Java/jre7/lib/ext/dns_sd.jar!/com/apple/dnssd/AppleBrowser.class]; nested exception is java.lang.IllegalArgumentException

昨天想升sturts漏洞,升完就报错了,现在返回去也是这个错误,求大神帮忙看看这是什么错误啊?跪谢了。。jar包也都升级到最新的了,还是不行。

4个回答

privateobject
privateobject   2017.09.18 15:46

是不是版本兼容的问题:ASM ClassReader没有解析的类文件,可能是由于新的java类文件的版本不支持

qq_27896387
qq_27896387   2017.09.18 16:48

ASM ClassReader没有解析 jar:file:/C:/Program%20Files/Java/jre7/lib/ext/dns_sd.jar!/com/apple/dnssd/AppleBrowser.class 文件

cashT
cashT   2017.09.18 17:17
检查Maven的类库,看有没有问题,有没有无asm显性依赖,其依赖是否产生于spring本身.
如果都没有错:
1.升级jdk版本
2.升级spring
两个方案二选一.希望能帮到你.
happyfaint000
happyfaint000   2017.09.20 18:13

建议,降下版本,尤其是 spring和jdk版本都降一下,,,,,新的,,总是很多问题,,,

Csdn user default icon
上传中...
上传图片
插入图片