编程介的小学生 2017-11-19 15:44 采纳率: 20.5%
浏览 902
已采纳

Infinite Go

Problem Description
  Go is a proverbial board game originated in China. It has been proved to be the most difficult board game in the world. “The rules of Go are so elegant, organic, and rigorously logical that if intelligent life forms exist elsewhere in the universe, they almost certainly play Go.” said Emanuel Lasker, a famous chess master.
  A Go board consists of 19 horizontal lines and 19 vertical lines. So there are 361 cross points. At the beginning, all cross points are vacant.
  Go is played by two players. The basic rules are:
  1. One player owns black stones and the other owns white stones.
  2. Players place one of his stones on any vacant cross points of the board alternately. The player owns black stones moves first.
  3. Vertically and horizontally adjacent stones of the same color form a chain.
  4. The number of vacant points adjacent (vertically or horizontally) to a chain is called the liberty of this chain. Once the chain has no liberty, it will be captured and removed from the board.
  5. While a player place a new stone such that its chain immediately has no liberty, this chain will be captured at once unless this action will also capture one or more enemy’s chains. In that case, the enemy’s chains are captured, and this chain is not captured.
  
  In effect, Go also has many advanced and complex rules. However, we only use these basic rules mentioned above in this problem.
  Now we are going to deal with another game which is quite similar to Go. We call it “Infinite Go”. The only difference is that the size of the board is no longer 19 times 19 -- it becomes infinite. The rows are numbered 1, 2, 3, ..., from top to down, and columns are numbered 1, 2, 3, ..., from left to right. Notice that the board has neither row 0 nor column 0, which means even though the board is infinite, it has boundaries on the top and on the left.
  In this problem, we are solving the problem that, given the actions of two players in a set of Infinite Go, find out the number of remaining stones of each player on the final board.

Input
  The input begins with a line containing an integer T (1 <= T <= 20), the number of test cases.
  For each test case, the first line contains a single integer N (1 <= N <= 10000), the number of stones placed during this set. Then follows N lines, the i-th line contains two integer X and Y (1 <= X, Y <= 2,000,000,000), indicates that the i-th stone was put on row X and column Y (i starts from 1). The stones are given in chronological order, and it is obvious that odd-numbered stones are black and even-numbered ones are white.

Output
  For each test case, output two integers Nb and Nw in one line, separated by a single space. Nb is the number of black stones left on the board, while Nw is the number of white stones left on the board.

Sample Input
1
7
5 5
4 5
3 5
3 4
4 4
3 3
4 6

Sample Output
4 2

  • 写回答

2条回答 默认 最新

  • $(X) 2018-07-17 14:56
    关注
    /*from:  https://blog.csdn.net/qq_37171272/article/details/77723013*/
    #include<iostream>
    
    #include<cstring>
    
    #include<cstdio>
    
    #include<map>
    
    #include<stack>
    
    #include<set>
    
    #include<algorithm>
    
    #define LL long long
    
    using namespace std;
    
    map<pair<int,int>,int> mp,vis;//mp存坐标及颜色,vis标记
    
    int n;
    
    pair<int,int> que[10005],tmp;
    
    int _next[4][2]={1,0,-1,0,0,1,0,-1};
    
    void bfs(int x,int y,int type)//type即颜色
    
    {
    
        vis.clear();
    
        int head=0,tail=-1;
    
        que[++tail]=make_pair(x,y);
    
        vis[make_pair(x,y)]=1;
    
        while(head<=tail)
    
        {
    
            tmp=que[head++];
    
            for(int i=0;i<4;i++)
    
            {
    
                int tx=tmp.first+_next[i][0];
    
                int ty=tmp.second+_next[i][1];
    
                if(tx>=1&&ty>=1&&vis[make_pair(tx,ty)]==0)
    
                {
    
                    if(mp[make_pair(tx,ty)]==0)//当前点周围有气,直接return
    
                        return;
    
                    else if(mp[make_pair(tx,ty)]==type)//与当前点的颜色相同入队
    
                        que[++tail]=make_pair(tx,ty);
    
                    vis[make_pair(tx,ty)]=1;//标记
    
                }
    
            }
    
        }
    
        for(int i=0;i<=tail;i++)//若之前没有return,说明当前连通块被全部围住,则需要清空
    
            mp[que[i]]=0;//不用stl里面的queue就是在这清空时方便
    
    }
    
    int main()
    
    {
    
        int t;
    
        scanf("%d",&t);
    
        while(t--)
    
        {
    
            mp.clear();
    
            scanf("%d",&n);
    
            int x,y;
    
            for(int i=1;i<=n;i++)
    
            {
    
                scanf("%d%d",&x,&y);
    
                mp[make_pair(x,y)]=i&1?-1:1;//每个点的颜色
    
                for(int i=0;i<4;i++)
    
                {
    
                    int tx=x+_next[i][0];
    
                    int ty=y+_next[i][1];
    
                    if(mp[make_pair(tx,ty)])
    
                        bfs(tx,ty,mp[make_pair(tx,ty)]);
    
                }
    
                bfs(x,y,i%1?-1:1);
    
            }
    
            int ans1=0,ans2=0;
    
            map<pair<int,int>,int>::iterator it;
    
            for(it=mp.begin();it!=mp.end();it++)//遍历mp,计算答案
    
            {
    
                if(it->second==-1) ans1++;
    
                if(it->second==1) ans2++;
    
            }
    
            printf("%d %d\n",ans1,ans2);
    
        }
    
        return 0;
    
    } 
    
    本回答被题主选为最佳回答 , 对您是否有帮助呢?
    评论
查看更多回答(1条)

报告相同问题?

悬赏问题

  • ¥20 delta降尺度方法,未来数据怎么降尺度
  • ¥15 c# 使用NPOI快速将datatable数据导入excel中指定sheet,要求快速高效
  • ¥15 再不同版本的系统上,TCP传输速度不一致
  • ¥15 高德地图点聚合中Marker的位置无法实时更新
  • ¥15 DIFY API Endpoint 问题。
  • ¥20 sub地址DHCP问题
  • ¥15 delta降尺度计算的一些细节,有偿
  • ¥15 Arduino红外遥控代码有问题
  • ¥15 数值计算离散正交多项式
  • ¥30 数值计算均差系数编程