2 apbbbbb apbbbbb 于 2018.02.02 14:35 提问

maven打包报错,用命令打包的mvn package 接着报这个错,急等

图片说明

图片说明
jdk用的1.8

pom.xml配置maven之后

<build>
    <plugins>
       <plugin>
            <groupId>org.apache.maven.plugins</groupId>
            <artifactId>maven-compiler-plugin</artifactId>
            <version>3.3</version>
            <configuration>
                <source>1.8</source>
                <target>1.8</target>
            </configuration>
        </plugin>
    </plugins>
    </build>

又报错
图片说明
通过

<build>
    <plugins>
       <plugin>
            <groupId>org.apache.maven.plugins</groupId>
            <artifactId>maven-compiler-plugin</artifactId>
            <version>3.3</version>
            <configuration>
                <source>1.8</source>
                <target>1.8</target>
                <encoding>UTF-8</encoding> 
                <compilerArguments>  
                        <verbose />  
                        <bootclasspath>${java.home}\lib\rt.jar;${java.home}\lib\jce.jar</bootclasspath>  
                </compilerArguments> 
            </configuration>
        </plugin>
    </plugins>
    </build>

解决

现在发布又出现了新问题

图片说明

7个回答

u013119405
u013119405   2018.02.02 15:04
已采纳

上面没有按照代码格式发,应该是这个。。。

 <plugin>
    <groupId>org.apache.maven.plugins</groupId>
    <artifactId>maven-compiler-plugin</artifactId><version>3.3</version>
    <configuration><source>1.5</source><target>1.5</target>/configuration>
</plugin>
apbbbbb
apbbbbb 回复FindBoy: 谢谢
22 天之前 回复
u013119405
u013119405 回复旋转的钢笔: 现在你的编译环境时1.8,那么你的运行时环境最少也要指定为1.8才可以
22 天之前 回复
u013119405
u013119405 回复旋转的钢笔: 后面哪个问题,你的运行环境你检查一下,运行时jre是哪个版本,这个问题一般是高版本代码用低版本jre引发的
22 天之前 回复
apbbbbb
apbbbbb 回复FindBoy: 新问题更新,请重新看问题
22 天之前 回复
u013119405
u013119405 回复旋转的钢笔: 新问题贴出来看看?是不是第一次编译pom下载的jar包有问题导致的
22 天之前 回复
apbbbbb
apbbbbb 加过之后又报好多程序包找不到是什么情况?
22 天之前 回复
Lucky_wss
Lucky_wss   2018.02.02 14:38

编译级别太低,需要指定到1.8

v59974
v59974 0000
22 天之前 回复
apbbbbb
apbbbbb 已经制定了,还是不行,jre切换成了1.8
22 天之前 回复
u013119405
u013119405   2018.02.02 15:02

配置maven编译使用版本

org.apache.maven.plugins
maven-compiler-plugin3.3
1.81.8/configuration>

这是maven编译使用的jdk版本不对导致的,你按照上面添加组件到pom里面就行了

u013119405
u013119405   2018.02.02 15:02

配置maven编译使用版本

org.apache.maven.plugins
maven-compiler-plugin3.3
1.81.8/configuration>

lin595052817
lin595052817   2018.02.02 15:49

问题是否解决,配置的maven环境,jdk需要更改成1.8 ,指向你本机的java_home

apbbbbb
apbbbbb 谢谢,但是又出现了新问题
22 天之前 回复
liu13816947142
liu13816947142   2018.02.02 15:51

mvn package --skip test 跳过测试,后面的错误最好换个image编解码的包

liu13816947142
liu13816947142 回复旋转的钢笔: 容器对应得tomcat版本是否也是JRE1.8版本得
22 天之前 回复
apbbbbb
apbbbbb 问题已更新,请重新查看
22 天之前 回复
zilong_zilong
zilong_zilong   2018.02.02 16:31
 在eclipse中你制定用1.8编译,那么部署的环境最少JDK要>=1.8
apbbbbb
apbbbbb 谢谢
22 天之前 回复
Csdn user default icon
上传中...
上传图片
插入图片
准确详细的回答,更有利于被提问者采纳,从而获得C币。复制、灌水、广告等回答会被删除,是时候展现真正的技术了!