编程介的小学生 2019-01-26 16:09 采纳率: 20.5%
浏览 359

C语言的函数算法去解决一个矩阵的问题,涉及到大数的计算怎么实现的?

Problem Description
In mathematics, the Fibonacci numbers are a sequence of numbers named after Leonardo of Pisa, known as Fibonacci (a contraction of filius Bonaccio, "son of Bonaccio"). Fibonacci's 1202 book Liber Abaci introduced the sequence to Western European mathematics, although the sequence had been previously described in Indian mathematics.
The first number of the sequence is 0, the second number is 1, and each subsequent number is equal to the sum of the previous two numbers of the sequence itself, yielding the sequence 0, 1, 1, 2, 3, 5, 8, etc. In mathematical terms, it is defined by the following recurrence relation:

That is, after two starting values, each number is the sum of the two preceding numbers. The first Fibonacci numbers (sequence A000045 in OEIS), also denoted as F[n];
F[n] can be calculate exactly by the following two expressions:

A Fibonacci spiral created by drawing arcs connecting the opposite corners of squares in the Fibonacci tiling; this one uses squares of sizes 1, 1, 2, 3, 5, 8, 13, 21, and 34;

So you can see how interesting the Fibonacci number is.
Now AekdyCoin denote a function G(n)

Now your task is quite easy, just help AekdyCoin to calculate the value of G (n) mod C

Input
The input consists of T test cases. The number of test cases (T is given in the first line of the input. Each test case begins with a line containing A, B, N, C (10<=A, B<2^64, 2<=N<2^64, 1<=C<=300)

Output
For each test case, print a line containing the test case number( beginning with 1) followed by a integer which is the value of G(N) mod C

Sample Input
1
17 18446744073709551615 1998 139

Sample Output
Case 1: 120

  • 写回答

2条回答 默认 最新

  • JW12138 2019-01-26 19:55
    关注

    这个不是大数,用unsigned long long就能装下,运算用快速幂套模板就行

    #include<iostream>
    #include<cstdio>
    using namespace std;
    int pow_mod(int a,int n,int m)//快速幂,a为底数,n为幂数,m为mod数;
    {
        if(n==0) return 1;
        int x=pow_mod(a,n/2,m);
        long long ans=(long long)x*x%m;
        if(n%2==1) ans=ans*a%m;
        return (int)ans;
    }
    int main()
    {
        int a,n,m;
        cin>>a>>n>>m;
        cout<<pow_mod(a,n,m)<<endl;
        return 0;
    }
    
    评论

报告相同问题?

悬赏问题

  • ¥20 有关区间dp的问题求解
  • ¥15 多电路系统共用电源的串扰问题
  • ¥15 slam rangenet++配置
  • ¥15 有没有研究水声通信方面的帮我改俩matlab代码
  • ¥15 对于相关问题的求解与代码
  • ¥15 ubuntu子系统密码忘记
  • ¥15 信号傅里叶变换在matlab上遇到的小问题请求帮助
  • ¥15 保护模式-系统加载-段寄存器
  • ¥15 电脑桌面设定一个区域禁止鼠标操作
  • ¥15 求NPF226060磁芯的详细资料