编程介的小学生 2019-02-23 12:59 采纳率: 20.5%
浏览 364

矩阵里元素交换的一个算法,如何利用C语言的编程的技术实现的办法

Problem Description
There is a matrix M that has n rows and m columns (1≤n≤1000,1≤m≤1000).Then we perform q(1≤q≤100,000) operations:

1 x y: Swap row x and row y (1≤x,y≤n);

2 x y: Swap column x and column y (1≤x,y≤m);

3 x y: Add y to all elements in row x (1≤x≤n,1≤y≤10,000);

4 x y: Add y to all elements in column x (1≤x≤m,1≤y≤10,000);

Input
There are multiple test cases. The first line of input contains an integer T(1≤T≤20) indicating the number of test cases. For each test case:

The first line contains three integers n, m and q.
The following n lines describe the matrix M.(1≤Mi,j≤10,000) for all (1≤i≤n,1≤j≤m).
The following q lines contains three integers a(1≤a≤4), x and y.

Output
For each test case, output the matrix M after all q operations.

Sample Input
2
3 4 2
1 2 3 4
2 3 4 5
3 4 5 6
1 1 2
3 1 10
2 2 2
1 10
10 1
1 1 2
2 1 2

Sample Output
12 13 14 15
1 2 3 4
3 4 5 6
1 10
10 1

  • 写回答

1条回答 默认 最新

  • LXZ_heng 2019-02-23 14:21
    关注
    #include<stdio.h>
    int main()
    {
        int T, n, m, k, i, j, tmp;
        scanf("%d", &T);
        while(T--)
        {
            scanf("%d%d%d", &n, &m, &k);
            int M[n][m];
            int a, x, y;
            for(i=0; i<n; i++)
            {
                for(j=0; j<m; j++)
                {
                    scanf("%d", &M[i][j]);
                }
            }
            while(k--)
            {
                scanf("%d%d%d", &a, &x, &y);
                if(a == 1)
                {
                    for(i=0; i<m; i++)
                    {
                        tmp = M[y-1][i];
                        M[y-1][i] = M[x-1][i];
                        M[x-1][i] = tmp;
                    }
                }
                else if(a == 2)
                {
                    for(i=0; i<n; i++)
                    {
                        tmp = M[i][y-1];
                        M[i][y-1] = M[i][x-1];
                        M[i][x-1] = tmp;
                    }
                }
                else if(a == 3)
                {
                    for(i=0; i<m; i++)
                        M[x-1][i] += y;
                }
                else{
                    for(i=0; i<n; i++)
                        M[i][x-1] += y;
                }
            }
            for(i=0; i<n; i++)
            {
                for(j=0; j<m; j++)
                {
                    printf("%d ", M[i][j]);
                }
                printf("\n");
            }
        }
        return 0;
    }
    
    评论

报告相同问题?

悬赏问题

  • ¥15 素材场景中光线烘焙后灯光失效
  • ¥15 请教一下各位,为什么我这个没有实现模拟点击
  • ¥15 执行 virtuoso 命令后,界面没有,cadence 启动不起来
  • ¥50 comfyui下连接animatediff节点生成视频质量非常差的原因
  • ¥20 有关区间dp的问题求解
  • ¥15 多电路系统共用电源的串扰问题
  • ¥15 slam rangenet++配置
  • ¥15 有没有研究水声通信方面的帮我改俩matlab代码
  • ¥15 ubuntu子系统密码忘记
  • ¥15 保护模式-系统加载-段寄存器