l_migrant 2021-09-19 11:14 采纳率: 83.3%
浏览 26
已结题

这段代码编译不通过的原因是什么?为什么不能通过。即可采纳

1455:An Easy Problem
查看提交统计提问
总时间限制: 1000ms 内存限制: 65536kB
描述
As we known, data stored in the computers is in binary form. The problem we discuss now is about the positive integers and its binary form.

Given a positive integer I, you task is to find out an integer J, which is the minimum integer greater than I, and the number of '1's in whose binary form is the same as that in the binary form of I.

For example, if "78" is given, we can write out its binary form, "1001110". This binary form has 4 '1's. The minimum integer, which is greater than "1001110" and also contains 4 '1's, is "1010011", i.e. "83", so you should output "83".
输入
One integer per line, which is I (1 <= I <= 1000000).

A line containing a number "0" terminates input, and this line need not be processed.
输出
One integer per line, which is J.
样例输入
1
2
3
4
78
0
样例输出
2
4
5
8
83


#include <iostream>
#include <cstring>
using namespace std;
int a[21],b[21],len,t,n,m;
void lowtrans(int);
void uptrans(int y[],int l);
int main()
{
    while(cin >> n && n)
    {
        memset(a,0,sizeof(a));    memset(b,0,sizeof(b));
        lowtrans(n);
        for(int i = 2; i <= len; i++)
        {
            if(!(a[i]))
            {
                b[i] = 1;
                for(i = 1; i <= t; i++)        b[i] = 0;
                break;
            }
        }
        uptrans(b[len + 1],len + 1);
    }
    return 0;
}
void lowtrans(int x)
{
    len = 1;    t = 0;
    while(x % 2)
    {
        x /= 2;
        a[len] = x % 2;
        if(a[len])    t++;
        len++;
    }
    cout << "lowtrans : ";
    for(int i = 1; i <= len; i++)    cout << a[i];
    cout << endl;
}
void uptrans(int y[],int l)
{
    for(int i = 1; i <= l; i++)
    {    
        if(y[i])
            for(int j = i; j > 0; j--)
                y[i] *= 2;
        b[i] = y[i];
    }
    cout << "uptrans : ";
    for(int i = 1; i <= len; i++)    cout << a[i];
    cout << endl;
}
  • 写回答

2条回答 默认 最新

  • 快乐鹦鹉 2021-09-19 12:30
    关注
        uptrans(b[len + 1],len + 1);
    

    这句话错了。b[len+1]是数组的第len+1个元素,是int型,但uptrans参数要求是数组。

    本回答被题主选为最佳回答 , 对您是否有帮助呢?
    评论
查看更多回答(1条)

报告相同问题?

问题事件

  • 系统已结题 9月27日
  • 已采纳回答 9月19日
  • 创建了问题 9月19日

悬赏问题

  • ¥30 自适应 LMS 算法实现 FIR 最佳维纳滤波器matlab方案
  • ¥15 lingo18勾选global solver求解使用的算法
  • ¥15 全部备份安卓app数据包括密码,可以复制到另一手机上运行
  • ¥15 Python3.5 相关代码写作
  • ¥20 测距传感器数据手册i2c
  • ¥15 RPA正常跑,cmd输入cookies跑不出来
  • ¥15 求帮我调试一下freefem代码
  • ¥15 matlab代码解决,怎么运行
  • ¥15 R语言Rstudio突然无法启动
  • ¥15 关于#matlab#的问题:提取2个图像的变量作为另外一个图像像元的移动量,计算新的位置创建新的图像并提取第二个图像的变量到新的图像