2 baifaxiaoyao baifaxiaoyao 于 2012.09.25 11:19 提问

Android错误:Android requires compiler compliance level 5.0

有人遇到同样的问题么?我导入android工程的时候就出现了这个错误

[2012-09-24 17:20:09 - Screen] Android requires compiler compliance level5.0 or6.0. Found '1.7' instead. Please useAndroid Tools > Fix Project Properties.
[2012-09-24 17:21:55 - App] Android requires compiler compliance level5.0 or6.0. Found '1.7' instead. Please useAndroid Tools > Fix Project Properties.
[2012-09-24 17:21:59 - App] Android requires compiler compliance level5.0 or6.0. Found '1.7' instead. Please useAndroid Tools > Fix Project Properties.

为了删除函数上的所有重写的方法,我得到了这个错误。我的是windows7 64位,64位的jvm7.有人知道这个错误么?(我用了Android Tools -> Fix Project Properties,但是不起作用)

2个回答

mansuifengqi
mansuifengqi   2012.09.25 13:17
已采纳

就像评论中说的,你必须设置工程的兼容性到Java5.0或Java6.0.
要这样做,有两个方法:
①正确点击你的工程,然后选择"Android Tools -> Fix Project Properties"(如果这个不行,试试第二个方法)
②正确点击你的工程然后选择"Properties -> Java Compiler",检查 "Enable project specific settings" ,然后从"Compiler compliance settings" 选项卡选择1.5或者1.6。

niangzhi
niangzhi   2012.09.25 13:46

我建议使用X86版本的jvm。当我第一次用我的新的笔记本电脑(64位),我一直都想要64位的(jvm,jdk,jre,eclipse等等)。但是一旦我将所有的都设置完了,我意识到android SDK不支持64位的,所以我遇到了问题。重新回到jvm 86版本,你的问题就能解决了。

Csdn user default icon
上传中...
上传图片
插入图片