错误:php55w-与CentOS 6.5上的php-common冲突

I have installed a fresh 64-bit CentOS 6.5 with PHP5, Mysql5.5, etc.

Now when I want to install different apache modules, like php-soap, I get this error:

---> Package php-soap.x86_64 0:5.3.3-27.el6_5 will be installed
--> Processing Dependency: php-common(x86-64) = 5.3.3-27.el6_5 for package: php-soap-5.3.3-27.el6_5.x86_64
--> Running transaction check
---> Package php-common.x86_64 0:5.3.3-27.el6_5 will be installed
--> Processing Conflict: php55w-common-5.5.12-1.w6.x86_64 conflicts php-common < 5.5.0
--> Finished Dependency Resolution
Error: php55w-common conflicts with php-common-5.3.3-27.el6_5.x86_64
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

I use this command to install php-soap:

yum --enablerepo=webtatic install php-soap

4个回答



我刚刚找到了我的问题的解决方案!</ p>

使用以下命令安装php- soap:</ p>

  yum install php55w-soap 
</ code> </ pre>

希望这会有所帮助!</ p>
</ DIV>

展开原文

原文

I just found the solution to my issue!

use the following command to install php-soap:

yum install php55w-soap

Hope this helps!

dpcj32769
dpcj32769 十分感谢。 为我工作安装php-mbstring与php55w-mbstring检查它是否正在安装:php -m | grep mbstring检查它是否已加载:php -r'php -r'echo extension_loaded(“mbstring”)? 1:2; '重启httpd服务谢谢
一年多之前 回复
drno94939847
drno94939847 sudo yum安装php56w-soap为我工作
3 年多之前 回复
dsi36131
dsi36131 sudo yum安装php56-soap为我工作
3 年多之前 回复
doukuo9116
doukuo9116 我在2017年1月运行了iSos 6.8 PHP 7,这对我有用:yum从webtatic.com/packages/php70安装php70w-soap
3 年多之前 回复
duangua5742
duangua5742 对我来说 - sudo yum安装php55-soap(删除w,并确保以sudo(root)身份运行
5 年多之前 回复
dongshi1934
dongshi1934 我正在安装XML模块,而不是SOAP,但更改命令到yum install php55w-xml工作了一个款待。 谢谢你!
接近 6 年之前 回复

I have installed postfix and dovecot on my Centos. I am using Interspire Email marketer (IEM) which needs php-imap module. I installed squirrelmail and can send out mails as well as receive mails using squirrelmail interface. But using IEM I always get error that imap module is not installed so I tried the following and got the errors below. I am totally confused what I should do. I thought if squirrelmail can read mails, IEM should also be able to read. If I must install php-imap again, what to do with all the errors below.

yum install php-imap 
Loaded plugins: fastestmirror
Setting up Install Process
Loading mirror speeds from cached hostfile
epel/metalink                                                                                                                                                           | 4.4 kB     00:00     
 * base: centos.webwerks.com
 * epel: mirror.premi.st
 * extras: centos.webwerks.com
 * updates: centos.webwerks.com
 * webtatic: sp.repo.webtatic.com
base                                                                                                                                                                    | 3.7 kB     00:00     
extras                                                                                                                                                                  | 3.4 kB     00:00     
updates                                                                                                                                                                 | 3.4 kB     00:00     
webtatic                                                                                                                                                                | 3.6 kB     00:00     
Resolving Dependencies
--> Running transaction check
---> Package php-imap.x86_64 0:5.3.3-48.el6_8 will be installed
--> Processing Dependency: php-common(x86-64) = 5.3.3-48.el6_8 for package: php-imap-5.3.3-48.el6_8.x86_64
--> Running transaction check
---> Package php-common.x86_64 0:5.3.3-48.el6_8 will be installed
--> Processing Conflict: php55w-common-5.5.38-1.w6.x86_64 conflicts php-common < 5.5
--> Finished Dependency Resolution
Error: php55w-common conflicts with php-common-5.3.3-48.el6_8.x86_64
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest



我使用以下命令解决同样的问题:

yum remove php *
yum install php55w-soap \ n </ code> </ p>
</ div>

展开原文

原文

I use the following command to solve the same issue: yum remove php* yum install php55w-soap



yum -y install php55w php55w-fpm php55w-soap php55w-opcache php55w-xml php55w-mcrypt php55w-gd php55w-devel php55w- mysql php55w-intl php55w-mbstring php55w-bcmath </ p>
</ div>

展开原文

原文

yum -y install php55w php55w-fpm php55w-soap php55w-opcache php55w-xml php55w-mcrypt php55w-gd php55w-devel php55w-mysql php55w-intl php55w-mbstring php55w-bcmath

Csdn user default icon
上传中...
上传图片
插入图片
抄袭、复制答案,以达到刷声望分或其他目的的行为,在CSDN问答是严格禁止的,一经发现立刻封号。是时候展现真正的技术了!
立即提问
相关内容推荐