douchou8935
2015-02-05 20:51 阅读 55
已采纳

将symfony从2.5.8更新到2.6后出错

I have just update symfony 2.5.8 to 2.6 and I have this error:

SCREAM: Error suppression ignored for
( ! ) Warning: require(D:\wamp\www\agence\vendor/symfony/intl/Symfony/Component/Intl/Resources/stubs/functions.php) 
[<a href='function.require'>function.require</a>]: 
failed to open stream: No such file or directory in D:\wamp\www\agence\vendor\composer\autoload_real.php on line 54

and this is the composer

"require": {
    "php": ">=5.3.3",
    "symfony/symfony": "2.6.*",
    "doctrine/orm": "~2.2,>=2.2.3,<2.5",
    "doctrine/dbal": "<2.5",
    "doctrine/doctrine-bundle": "~1.2",
    "twig/extensions": "~1.0",
    "symfony/assetic-bundle": "~2.3",
    "symfony/swiftmailer-bundle": "~2.3",
    "symfony/monolog-bundle": "~2.4",
    "sensio/distribution-bundle": "~3.0,>=3.0.12",
    "sensio/framework-extra-bundle": "~3.0,>=3.0.2",
    "incenteev/composer-parameter-handler": "~2.0",
    "friendsofsymfony/user-bundle": "dev-master",
    "symfony/intl": "~2.3",
    "symfony/locale": "2.6.4",
    "friendsofsymfony/message-bundle": "dev-master",
    "stof/doctrine-extensions-bundle": "dev-master",
    "gedmo/doctrine-extensions": "dev-master",
    "knplabs/knp-paginator-bundle": "~2.4",
    "liip/imagine-bundle": "dev-master"
},

it was working good , I don't know what happened

  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 复制链接分享

1条回答 默认 最新

  • 已采纳
    douxian7117 douxian7117 2015-02-05 21:23

    Remove this dependency "symfony/intl": "~2.3", this component is already included in symfony/symfony and the version constraint does not match for the desired release (2.6.*)

    点赞 评论 复制链接分享

相关推荐