douyong1908
2018-06-20 08:01
浏览 25
已采纳

在安装Bitexchange脚本时在浏览器中获取PHP代码

I am trying to Install Bitexhchange script on Localhost, after successfully doing all changes, I am getting PHP code in my browser

enter image description here

bitexchnage support page.

<?
include 'lib/common.php';
ini_set("memory_limit","200M");
$CFG->print = $_REQUEST['print'];
$CFG->url = ($_REQUEST['current_url'] != 'index.php') ? ereg_replace("[^a-zA-Z_\-]", "",$_REQUEST['current_url']) : '';
$CFG->action = ereg_replace("[^a-zA-Z_\-]", "",$_REQUEST['action']);
$CFG->bypass = ($_REQUEST['bypass'] || $CFG->print);
$CFG->is_tab = (!$CFG->url) ? 1 : $_REQUEST['is_tab'];
$CFG->id = ereg_replace("[^0-9]", "",$_REQUEST['id']);
$CFG->target_elem = ereg_replace("[^a-zA-Z_\-]", "",$_REQUEST['target_elem']);
$CFG->in_popup = ($CFG->target_elem == 'edit_box' || $CFG->target_elem == 'message_box' || $CFG->target_elem == 'attributes box');
$CFG->inset_id = false;
$_SESSION['last_query'] = $_SESSION['this_query'];
$_SESSION['this_query'] = 'index.php?'.http_build_query((is_array($_POST)) ? $_POST : $_GET);

date_default_timezone_set($CFG->default_timezone);
String::magicQuotesOff();
  • 写回答
  • 好问题 提建议
  • 追加酬金
  • 关注问题
  • 收藏
  • 邀请回答

1条回答 默认 最新

  • doumen9709 2018-06-20 09:11
    已采纳

    Your php is probably not configured to accept the short open tags (<?)

    You should either enable it into your php.ini file (see How to enable PHP short tags? ) or use the "long" php open tag : <?php

    评论
    解决 无用
    打赏 举报

相关推荐 更多相似问题