duandao1931
duandao1931
2016-05-25 06:32

XAMPP apache服务无法启动

已采纳

When i trying to start apache services i show the following erron in error block panel

11:51:30 AM [Apache] Status change detected: stopped
11:51:30 AM [Apache] Error: Apache shutdown unexpectedly.
11:51:30 AM [Apache] This may be due to a blocked port, missing dependencies,
11:51:30 AM [Apache] improper privileges, a crash, or a shutdown by another method.
11:51:30 AM [Apache] Press the Logs button to view error logs and check
11:51:30 AM [Apache] the Windows Event Viewer for more clues
11:51:30 AM [Apache] If you need more help, copy and post this
11:51:30 AM [Apache] entire log window on the forums

plese someone help me

  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 复制链接分享
  • 邀请回答

2条回答

  • dpp3047 dpp3047 5年前

    Hello if you are using Skype then from Skype Tools->options->Advanced->Connection in this check Use-port there one text box may be there default port using 80 so make that box empty. and save logout from Skype and login again now your skype use port other than 80 so now your Apache is working fine.

    And there is other solution is also you can also change your default port for Apache 80 to other from Apache httpd.conf ServerName localhost:80 to any other free port like ServerName localhost:81 may helps you.

    点赞 评论 复制链接分享
  • duanguoyin7008 duanguoyin7008 4年前

    Here's how I figured it out:

    1. In Control Panel, click on Apache ---- Config button and open the file in the first line (httpd.conf), here

    2. Search for these lines
      #Listen 12.34.56.78:80

      Listen 80

      ServerName localhost:80

    And replace 80 in these lines by another number x, probably a unique one to avoid duplicate. Eg, 2017.

    1. In Control Panel, click on Config button in upper right corner, here.

      Service and Port Settings > Main Port: replace the old one with x

    That's how mine works. Hope it helps you.

    点赞 评论 复制链接分享