dsi37923
2014-03-13 16:21
浏览 68
已采纳

OSX:PHP错误localhost,无法加载动态库

How can i fix this php error?

PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/lib/php/extensions/no-debug-non-zts-20100525/php_pdo_mysql.dll' - dlopen(/usr/lib/php/extensions/no-debug-non-zts-20100525/php_pdo_mysql.dll, 9): image not found in Unknown on line 0

I am on a mac/mavericks and I have made a mistake and did a sudo cp /private/etc/php.ini.default /private/etc/php.ini so now I get the error stated above when I run php -v

图片转代码服务由CSDN问答提供 功能建议

如何修复此php错误?

  PHP警告:PHP启动:无法加载动态库'/usr/lib/php/extensions/no-debug-non-zts-20100525/php_pdo_mysql.dll' -  dlopen(/usr/lib/php/extensions/no-debug-non-zts-20100525/php_pdo_mysql.dll,9):在第0行的未知中找不到图像
   
 
  

我在mac / mavericks上犯了一个错误并且做了一个 sudo cp /private/etc/php.ini.default /private/etc/php.ini 所以现在我得到了 当我运行 php -v 时,上述错误

  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 邀请回答

3条回答 默认 最新

  • dongpu2727 2015-07-02 12:47
    已采纳

    Originally, I followed these step-by-step guides to set up apache, php, mysql, etc and and get my localhost working:

    1. http://brianflove.com/2013/10/23/os-x-mavericks-and-apache/
    2. http://coolestguidesontheplanet.com/install-mcrypt-php-mac-osx-10-9-mavericks-development-server/

    Then, I accidentally replaced my php.ini file and got the error stated above in the question. Actually, at first I got the mcrypt missing error.

    So, after fixing all of these, I had few things left to do in the php.ini file:

    1. Declared mcrypt like this: extension=mcrypt.so

    2. Uncommented the extension_dir line and added: extension_dir = "/usr/lib/php/extensions/no-debug-non-zts-20100525/"

    3. I commented out the line: extension=php_pdo_mysql.dll

    4. Done a sudo apachectl restart

    Finally, everything works as is expected.

    点赞 评论
  • douxi1968 2014-11-13 08:51

    Follow this as it worked for me...

    The error coming for me was:

    $ sudo php -v
    # PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/lib/php/extensions/no-debug-non-zts-20121212/phalcon.so' - dlopen(/usr/lib/php/extensions/no-debug-non-zts-20121212/phalcon.so, 9): image not found in Unknown on line 0
    # PHP 5.5.14 (cli) (built: Sep  9 2014 19:09:25) 
    # Copyright (c) 1997-2014 The PHP Group
    # Zend Engine v2.5.0, Copyright (c) 1998-2014 Zend Technologies
    

    Run this as root:

    $ locate phalcon.so
    # /opt/local/lib/php55/extensions/no-debug-non-zts-20121212/phalcon.so
    

    Run this also as root:

    $ cp -rp /opt/local/lib/php55/extensions/no-debug-non-zts-20121212/phalcon.so /usr/lib/php/extensions/no-debug-non-zts-20121212/
    

    Just edit the directories as they might differ for you.

    点赞 评论
  • douzepao0281 2017-08-04 15:00

    In the php.ini file, if you had a unique extensions folder as required in macOS Sierra, make sure the extensions directory read like:

    extension=/usr/local/lib/php/extensions/mcrypt.so
    

    It's easy to forget to add the first "/"

    点赞 评论

相关推荐 更多相似问题