2015-01-15 18:50
浏览 33


I'm using chef for the first time, trying to get my head around recipes and cookbooks.

I receiving the error 'mysql::client' fails after configuring the standard php cookbook which I'm currently doing in my roles file:


override_attributes 'php' => {
'install_method' => "source",
'version' => "5.5",
'packages' => ["php55w", "php55w-devel", "php55w-pear", "php55w-cli", "php55w-pdo", "php55w-fpm", "php55w-intl", "php55w-mbstring", "php55w-mcrypt", "php55w-pecl-memcache", "php55w-pecl-xdebug", "php55w-process", "php55w-xml"]

(I've written my own webtatics cookbook which basically fetches the webtatics rpm):

# Go get web tatic
remote_file "#{Chef::Config[:file_cache_path]}/webtatic_repo_latest.rpm" do
    source ""
    action :create

rpm_package "jmxtrans" do
    source "#{Chef::Config[:file_cache_path]}/webtatic_repo_latest.rpm"
    action :install

I've tracked the error to the line:

include_recipe 'mysql::client' if configure_options =~ /mysql/

in the php cookbook, but I have no idea how to disable it from running and I can't simply replace the line as it comes from Berkshelf and get's overwritten.

Apparently mysql:client is no longer a valid way of installing mysql so I'm not sure why it's there. Is this a bug or can I override this?


  • 写回答
  • 好问题 提建议
  • 追加酬金
  • 关注问题
  • 邀请回答

1条回答 默认 最新

相关推荐 更多相似问题