duangutian1426
2012-10-11 15:21
浏览 73
已采纳

与brew一起安装go,并运行getour

I was following the http://tour.golang.org/ untill I got to the third step about that tells you that you can install the gotour on your system. After that I've installed the go language with brew by:

brew install hg
brew install go

Then I downloaded the gotour by:

go get code.google.com/p/go-tour/gotour

When I tried to launch the gotour it didnt recognise the command:

$ gotour
-bash: gotour: command not found

and

$ go gotour

and

$ ./gotour

So I tried to see the go path and it was empty,

echo $GOPATH

so I defined the GOPATH:

GOPATH=/usr/local/Cellar/go/1.0.2/src/pkg/code.google.com/p/
export GOPATH

Now I can run the gotour by runing

./gotour

But I'm insecure about my go enviroment.. wasn't I suposed to be able to run gotour by

go run gotour

or just by typing (like is described on this website http://www.moncefbelyamani.com/how-to-install-the-go-tour-on-your-mac/):

gotour

I would like to know if i'm doing things the right way since I'm new to the go programing language.

图片转代码服务由CSDN问答提供 功能建议

我正在关注 http:/ /tour.golang.org/ 直到执行第三步为止,直到您告诉您可以在系统上安装gotour。 此后,我用brew by安装了go语言:

  brew install hg 
brew install go 
   
 
 

然后我通过以下方式下载了getour: < pre> 开始获取code.google.com/p/go-tour/gotour

当我尝试启动getour时,它无法识别该命令:

  $ gotour 
-bash:gotour:找不到命令
   
 
 

  $ goourour 
   
 
 

  $ ./gotour
 <  / code>  
 
 

所以我尝试查看go路径,它为空,

  echo $ GOPATH 
    
 
 

所以我定义了GOPATH:

  GOPATH = / usr / local / Cellar / go / 1.0.2 / src / pkg /  code.google.com/p/
导出GOPATH 
   
 
 

现在我可以通过 正在运行

  ./ gotour 
   
 
 

但是我对围棋环境并不安全..不是 应该能够通过

 去运行gotour 
   
 
 

在此网站上 http://www.moncefbelyamani.com/how- 安装的最gotour-上的-MAC / ):

 <代码> gotour 
   
 \  n 

我想知道自从对Go编程语言不熟悉以来,我是否在正确地做事。

  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 邀请回答

6条回答 默认 最新

  • dongtong0796 2014-12-30 17:36
    已采纳

    Installing go 1.4 with homebrew on OSX:

    1) Create Directories

    mkdir $HOME/Go
    mkdir -p $HOME/Go/src/github.com/user
    

    2) Setup your paths

    export GOPATH=$HOME/Go
    export GOROOT=/usr/local/opt/go/libexec
    export PATH=$PATH:$GOPATH/bin
    export PATH=$PATH:$GOROOT/bin
    

    3) Install Go

    brew install go
    

    4) "go get" the basics

    go get golang.org/x/tools/cmd/godoc
    

    5) Start here: https://golang.org/doc/code.html at "your first program"

    点赞 打赏 评论
  • dongqinta4174 2012-10-12 15:20

    I think I have found the solution, I should have exported:

    export PATH=$PATH:/usr/local/Cellar/go/1.0.2/bin/
    

    Instead of

    GOPATH=/usr/local/Cellar/go/1.0.2/src/pkg/code.google.com/p/
    export GOPATH
    

    Since thats where 'go get' puts the binaries (I guess). gotour is working:

    $ gotour
    2012/10/11 18:35:50 Serving content from /usr/local/Cellar/go/1.0.2/src/pkg/code.google.com/p/go-tour
    2012/10/11 18:35:50 Open your web browser and visit http://127.0.0.1:3999/ 
    

    Btw I based my answer on this post

    http://code.google.com/p/go-tour/issues/detail?id=39 where they talk about exporting:

    /usr/local/Cellar/go/1.0.2/src/pkg/code.google.com/p/
    

    And the getting started page from go: http://golang.org/doc/install where they say you have to export:

    export PATH=$PATH:/usr/local/go/bin
    
    点赞 打赏 评论
  • douren8379 2013-05-03 15:25

    I thing you should have set the GOPATH before you go get. Well, at least here in my machine this worked smoothly.

    I set the GOPATH to a folder in my home folder.

    Hope this helps!

    点赞 打赏 评论
  • dptpn06684 2014-07-18 03:36

    Just an update here - I ran into this same problem, and the previous answers did NOT help. On current (~1.2.2) versions of Go installed by Homebrew, you have to set GOROOT to the following:

    export GOROOT=/usr/local/Cellar/go/1.2.2/libexec

    I'm a little unfamiliar with the go folder structure, or changes to the go installation via homebrew, so I don't really know why. But - if you're missing what seems like all the core packages, the above should fix.

    点赞 打赏 评论
  • dqu92800 2016-02-22 00:21

    I put this in my ${HOME}/.bash_profile

    export GOPATH="${HOME}/.go"
    export GOROOT="$(brew --prefix golang)/libexec"
    export PATH="$PATH:${GOPATH}/bin:${GOROOT}/bin"
    
    test -d "${GOPATH}" || mkdir "${GOPATH}"
    test -d "${GOPATH}/src/github.com" || mkdir -p "${GOPATH}/src/github.com"
    

    based on golfadas answer but updated to work with old and new versions of brew.

    点赞 打赏 评论
  • douchenchepan6465 2016-10-19 11:08

    Following a mix of answers above, this is what worked for me on OSX 10.12 (Sierra) and Go v1.7.1 using Homebrew:

    I added this from Kosh's answer to my .zshrc or .bashrc:

    # Go development
    export GOPATH="${HOME}/.go"
    export GOROOT="$(brew --prefix golang)/libexec"
    export PATH="$PATH:${GOPATH}/bin:${GOROOT}/bin"
    
    test -d "${GOPATH}" || mkdir "${GOPATH}"
    test -d "${GOPATH}/src/github.com" || mkdir -p "${GOPATH}/src/github.com"
    

    Then in a new terminal window/tab:

    $ brew install go
    ==> Downloading https://homebrew.bintray.com/bottles/go-1.7.1.sierra.bottle.tar.gz
    Already downloaded: /Users/nigel/Library/Caches/Homebrew/go-1.7.1.sierra.bottle.tar.gz
    ==> Pouring go-1.7.1.sierra.bottle.tar.gz
    ==> Caveats
    As of go 1.2, a valid GOPATH is required to use the go get command:
    https://golang.org/doc/code.html#GOPATH

    You may wish to add the GOROOT-based install location to your PATH:
    export PATH=$PATH:/usr/local/opt/go/libexec/bin
    ==> Summary

    点赞 打赏 评论

相关推荐 更多相似问题