dongpu2476
2015-10-08 16:21
浏览 101
已采纳

Go worker应用未在Cloud Foundry中启动

I am trying to run a go worker app (no binding to a route) in Cloud Foundry. I can start the Go binary locally and it works fine.

When the app tries to start in Cloud Foundry I get the following error.

2015-10-08T12:23:50.49-0400 [STG/127]    OUT -----> Downloaded app package (1.1M)
2015-10-08T12:23:53.48-0400 [STG/127]    OUT -----> Downloaded app buildpack cache (75M)
2015-10-08T12:23:55.45-0400 [STG/0]      ERR Cloning into '/tmp/buildpacks/go-buildpack'...
2015-10-08T12:23:57.48-0400 [STG/0]      OUT Submodule 'compile-extensions' (https://github.com/cloudfoundry/compile-extensions.git) registered for path 'compile-extensions'
2015-10-08T12:23:57.53-0400 [STG/0]      ERR Cloning into 'compile-extensions'...
2015-10-08T12:23:58.51-0400 [STG/0]      OUT Submodule path 'compile-extensions': checked out 'b5e0cf7be729718d162d56709ec7f27d34e68c7c'
2015-10-08T12:23:58.58-0400 [STG/0]      OUT -------> Buildpack version 1.6.2
2015-10-08T12:23:58.65-0400 [STG/0]      OUT -----> Checking Godeps/Godeps.json file.
2015-10-08T12:23:58.69-0400 [STG/0]      OUT -----> Using go1.5.1
2015-10-08T12:23:58.73-0400 [STG/0]      OUT -----> Running: godep go install -tags cloudfoundry ./...
2015-10-08T12:24:01.01-0400 [STG/127]    OUT -----> Uploading droplet (1.8M)
2015-10-08T12:24:23.98-0400 [DEA/127]    OUT Starting app instance (index 0) with guid 8b427c83-67b7-463e-99cd-53a4ad4154ac
2015-10-08T12:24:37.04-0400 [API/1]      OUT App instance exited with guid 8b427c83-67b7-463e-99cd-53a4ad4154ac payload: {"cc_partition"=>"default", "droplet"=>"8b427c83-67b7-463e-99cd-53a4ad4154ac", "version"=>"9f5da0a0-1b4c-4907-a92a-40b4ce6d5669", "instance"=>"73b999f6770949098d59bef51e81d31d", "index"=>0, "reason"=>"CRASHED", "exit_status"=>126, "exit_description"=>"failed to start", "crash_timestamp"=>1444321477}
2015-10-08T12:24:37.04-0400 [API/8]      OUT App instance exited with guid 8b427c83-67b7-463e-99cd-53a4ad4154ac payload: {"cc_partition"=>"default", "droplet"=>"8b427c83-67b7-463e-99cd-53a4ad4154ac", "version"=>"9f5da0a0-1b4c-4907-a92a-40b4ce6d5669", "instance"=>"73b999f6770949098d59bef51e81d31d", "index"=>0, "reason"=>"CRASHED", "exit_status"=>126, "exit_description"=>"app instance exited", "crash_timestamp"=>1444321477}

Below is my Procfile.

worker: ./slack-disable-2fa

Below is my manifest.yml file.

applications:
- path: .
  memory: 512MB
  instances: 1
  domain: mybluemix.net
  name: myapp
  host: myapp
  no-route: true
  disk_quota: 1024M
  command: ./slack-disable-2fa
  buildpack: https://github.com/cloudfoundry/go-buildpack.git

Snippet from the go app (slack-disable-2fa.go)

package main

import (
    "fmt"
    "time"
)


func main() {

    for {
        fmt.Printf("hello
")
        fmt.Printf("Running again in 24 hours...
")
        time.Sleep(time.Hour * 1)
    }

}
  • 写回答
  • 好问题 提建议
  • 关注问题
  • 收藏
  • 邀请回答

1条回答 默认 最新

  • dongwusang0314 2015-10-08 16:58
    已采纳

    Remove the './' prefix from the Procfile.

    It should only contain the command name.

    worker: slack-disable-2fa
    

    Also Remove the './' prefix from the manifest.yml.

      command: slack-disable-2fa
    
    已采纳该答案
    评论
    解决 无用
    打赏 举报

相关推荐 更多相似问题