doucu7330 2014-01-09 13:00
浏览 81
已采纳

在OSX上Go安装期间出现Ld错误

I try to build Go 1.2 from source but can't get it to work anymore. It worked yesterday but now ld always fails. I tried to reinstall Xcode command line tools. This is my Terminal output:

$ hg update go1.2
$ cd src
$ ./all.bash
# Building C bootstrap tool.
cmd/dist
ld: can't write output file: cmd/dist/dist for architecture x86_64
clang: error: linker command failed with exit code 1 (use -v to see invocation)

I am running OSX 10.9.1.

What could have happened that this error shows? (It worked yesterday, I just played around with homebrew)

What else can I do BESIDES reinstalling OSX?

  • 写回答

1条回答 默认 最新

  • duanhuan6857 2014-01-09 13:30
    关注

    Thanks to the comment of Volker I reapplied the correct permissions to the go folder. I didn't finde a specific folder that had the false permissions but resetting them for the whole go folder fixed it.

    I did not think this would be an issue because I installed go in my home folder.

    本回答被题主选为最佳回答 , 对您是否有帮助呢?
    评论

报告相同问题?

悬赏问题

  • ¥20 qt中connect两个signal
  • ¥20 pix2pixHD运行测试命令时出现数据类型错误无法反向传播的问题
  • ¥15 python处理Excel符合条件的行自动填写数据分类
  • ¥15 汇编hook举例并讲解(通俗易懂,学习用)
  • ¥20 用c++语言模拟键盘电子琴设计
  • ¥15 STM32cubemx生成keil工程,有问题与正常的情况不同,求解!
  • ¥15 如何自动点击银行app的安全键盘,实现密码自动输入
  • ¥15 关于四边形重叠的问题
  • ¥15 用verilog语言设计一个简易的八音符电子琴,可通过按键输入来控制音响。演奏时可以选择是手演奏(由键盘输入)或自动演奏已存入的乐曲。能够自动演奏多首乐曲,且每首乐曲可重复演奏
  • ¥15 sap gui脚本每次到导出Excel的时候就停住不动。不会另存为。